View Issue Details

IDProjectCategoryView StatusLast Update
0000580FreeCADBugpublic2014-11-23 10:10
ReporterthomasbogueAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.15 
Summary0000580: problem cutting away a particular sphere from a particular cylinder
DescriptionI was designing an object with a script (attached), and found a strange situation. When I used the TopoShape.cut operation, material was added, or rather XOR'ed.

After one cut operation, additional material is added (perhaps also removed -- I cannot tell). A second cut operation with the same sphere removes this extra material, leaving the cylinder unchanged. A third cut operation puts the extra material back.

Changing the particular values used for radius, et c. can make the operation function normally again. Removing either the stretch or rotation operations causes the problem to disappear.
TagsNo tags attached.

Activities

2012-01-25 12:49

 

cut-example.FCMacro (Attachment missing)

wmayer

2012-01-26 09:10

administrator   ~0001604

Note, the boolean operations (BOP) in the OCC kernel very often fail and we have no control on this. But there is one thing you can do: BOP with solids built out of B-Spline surfaces work really bad. So, whenever possible you should avoid using B-Splines.

And that's what is happening here: you use the transformGeometry() method and this always converts the underlying geometry into a B-Spline surface.

I know that in your example you need an ellipsoid and since OCC has no built-in support for this the transformGeometry method is the only way to go.

wmayer

2014-11-23 10:10

administrator   ~0005338

Not reproducible with newer OCC version (tested with 6.6)

Issue History

Date Modified Username Field Change
2012-01-25 12:49 thomasbogue New Issue
2012-01-25 12:49 thomasbogue File Added: cut-example.FCMacro
2012-01-26 09:10 wmayer Note Added: 0001604
2014-11-23 10:10 wmayer Note Added: 0005338
2014-11-23 10:10 wmayer Status new => closed
2014-11-23 10:10 wmayer Assigned To => wmayer
2014-11-23 10:10 wmayer Resolution open => fixed
2014-11-23 10:10 wmayer Fixed in Version => 0.15