View Issue Details

IDProjectCategoryView StatusLast Update
0000058FreeCADFeaturepublic2010-01-01 12:01
Reporteryorik Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.9 
Target VersionFixed in Version0.10 
Summary0000058: Export B-splines to dxf format
DescriptionB-splines should be exported as DXF polylines, with a generic system so other kinds of curves (trimmedcurves, etc) can also be exported easily in the future
Additional InformationDiscussion thread: http://sourceforge.net/apps/phpbb/free-cad/viewtopic.php?f=3&t=182
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2009-12-29 19:54

administrator   ~0000116

Done in r2769
There is now an option in the Draft preferences to set the max length of polyline segments for rendering splines into DXF polylines. If set to 0, the spline is rendered as a straight line.

Since I realized that qCAD itself did it that way (segmenting splines into polylines), I thought it was good enough for us too...

Issue History

Date Modified Username Field Change
2009-12-13 16:50 yorik New Issue
2009-12-13 16:51 yorik Status new => assigned
2009-12-13 16:51 yorik Assigned To => yorik
2009-12-29 19:54 yorik Note Added: 0000116
2009-12-29 19:54 yorik Status assigned => resolved
2009-12-29 19:54 yorik Fixed in Version => 0.10
2009-12-29 19:54 yorik Resolution open => fixed
2010-01-01 12:01 wmayer Status resolved => closed