View Issue Details

IDProjectCategoryView StatusLast Update
0000057FreeCADBugpublic2010-01-10 15:42
ReporteryorikAssigned Toyorik 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9 
Target VersionFixed in Version0.10 
Summary0000057: Draft Offset needs improvement
DescriptionDraft offset tool needs improvement, it is way too slow (mainly because of 3D vector rotations) and sometimes there are inversions in edge directions.
TagsNo tags attached.

Activities

yorik

2010-01-10 15:42

administrator   ~0000138

done in r2837
adopted an alternative (faster) redraw when the object to offset is made only of straight segments. Also, fcvec.angle now gives correct signed angle in whole 3D space

Issue History

Date Modified Username Field Change
2009-12-13 16:46 yorik New Issue
2009-12-13 16:46 yorik Status new => assigned
2009-12-13 16:46 yorik Assigned To => yorik
2010-01-10 15:42 yorik Note Added: 0000138
2010-01-10 15:42 yorik Status assigned => closed
2010-01-10 15:42 yorik Resolution open => fixed
2010-01-10 15:42 yorik Fixed in Version => 0.10