View Issue Details

IDProjectCategoryView StatusLast Update
0000053FreeCADFeaturepublic2010-01-12 18:40
ReporterunauthenticatedAssigned ToJriegel 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version0.9 
Target VersionFixed in Version 
Summary0000053: Creation of planes from closed objects (lines / circles)
DescriptionHi,

this is only suggestion / improvement for better usability of free cad.

Program should ask user if he wants to do a plane from closed line. I use to work with autodesk inventor and when I draw few lines it is possible to choose it as an plane for extrude.

Current extrude does not make sense to me because of two reasons:
(please correct me if I am wrong)
1. you can extrude only plane and you will create a box
2. if you extrude closed line you will create something like shell. And this is not a real 3D object. Even if it is I see faster modeling by extruding these object.

Best regards
Peter
TagsNo tags attached.

Activities

Jriegel

2009-12-12 18:34

administrator   ~0000052

Hi in the sense of the Part module its OK. Because the part module
only grand access to the basic operations of the CAD kernel.
That means extrusion works that way.

What you think of will be in the PartDesign module and is called
PadFeature. It makes a Solid out of a wire or a face. It also
respect inner wires which yield holes. But that features is
so far partially implemented.

supiik

2009-12-12 19:05

reporter   ~0000055

is it possible to find these features (extrude from a wire or a face) in 0.9?

If I am wrong and behavior is as expected please set this issue as invalid.

Peter

Jriegel

2009-12-12 19:20

administrator   ~0000056

You can reach the PartDesign workbench through View->Workbench->PartDesign

But it wont help you much ;-)

As I said the work flow of the parametric prismatic design
is not finished yet...

My be after the Christmas holidays in the 0.10 you see more of it....

Jriegel

2010-01-12 18:40

administrator   ~0000145

The Pad feature in PartDesign does the job now.

Issue History

Date Modified Username Field Change
2009-12-12 17:03 unauthenticated New Issue
2009-12-12 18:34 Jriegel Note Added: 0000052
2009-12-12 18:44 Jriegel Status new => assigned
2009-12-12 18:44 Jriegel Assigned To => Jriegel
2009-12-12 19:05 supiik Note Added: 0000055
2009-12-12 19:20 Jriegel Note Added: 0000056
2010-01-12 18:40 Jriegel Note Added: 0000145
2010-01-12 18:40 Jriegel Status assigned => closed
2010-01-12 18:40 Jriegel Resolution open => fixed