View Issue Details

IDProjectCategoryView StatusLast Update
0000512ArchFeaturepublic2013-10-18 18:51
Reporteryorik Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionno change required 
Product Version 
Target Version0.14Fixed in Version0.14 
Summary0000512: Arch module - Styles
DescriptionAdd a system to specify component styles. Those styles should be Geometry-less Document objects, so they can be easily copied from one document to another, or saved as libraries, and be stored inside a closed group, so it doesn't clutter the tree.

Those styles would defined how components like walls, structures or windows are to be constructed based on their base geometry. They would also include materials once that interface is available.

This would also serve to prove my point that it would be good to have the materials interface to use document objects too ;)
TagsNo tags attached.
FreeCAD Information

Relationships

parent of 0000517 closedyorik Arch module - predefined styles 

Activities

yorik

2013-10-18 18:51

administrator   ~0003767

Cancelled because now we're using presets...

Issue History

Date Modified Username Field Change
2011-12-05 12:38 yorik New Issue
2011-12-05 12:38 yorik Status new => assigned
2011-12-05 12:38 yorik Assigned To => yorik
2012-05-04 13:13 yorik Project FreeCAD => Arch
2012-05-06 21:13 yorik Relationship added parent of 0000517
2012-06-12 16:57 yorik Target Version 0.13 => trunk
2012-08-31 11:34 yorik Target Version trunk => 0.14
2013-10-18 18:51 yorik Note Added: 0003767
2013-10-18 18:51 yorik Status assigned => closed
2013-10-18 18:51 yorik Resolution open => no change required
2013-10-18 18:51 yorik Fixed in Version => 0.14