View Issue Details

IDProjectCategoryView StatusLast Update
0000490FreeCADFeaturepublic2014-08-08 01:38
ReporterjmaustpcAssigned Toyorik 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target Version0.15Fixed in Version0.15 
Summary0000490: Inbuilt scripts (macros) - better GUI access
DescriptionHi Guys
I know its way too late but I have a feature request for 0.12!!!

Can we put some sort of link in the menu or something somewhere in the GUI to give access to the "built in scripts" in the modules?

Why: -
They are very impressive to a new user
It reminds people that the scripts are there
Not really a new feature, just advertising the existing feature

How: -
I'm open to suggestions
simple option: - A link to the various scripts directory from the "tools" menu, called something like "inbuilt scripts", or "Python script examples", or "inbuilt macros" or other
more involved option: - A new menu, or sub-menu possibly under "tools" menu, with links to each individual script, possibly all using the same (Python?) icon, or even better, but too much for now, different appropriate icons each


I thought I would throw this thought out there because I think it would make quite an impact for someone new looking into FreeCAD at first.

Jim
TagsNo tags attached.

Activities

yorik

2011-11-24 01:02

administrator   ~0001345

There is already such a feature in the Draft workbench (it is there as a test, mainly)... I can add that to the complete workbench, if everybody finds suitable. But I'd rather do that after 0.12.

jmaustpc

2011-11-24 08:45

manager   ~0001349

Hi Yorik
I found that a while ago and I really liked it. But I had actually forgotten about it again.

I think it is a generic type feature that should be in -all- work benches. Definitely not just complete and Draft, to me that does not make sense, I mean as it is a generic feature, not a draft feature, in my opinion.

This is really a different feature to what I am meaning. On my set up at least, it only shows "my macros".

What I think would be good, as early as possible would be perhaps something similar but for ONLY the FreeCAD in-built macros. They are presumably reasonably well written and properly functional?

If so then I saw this as more of an advertising of existing functions rather than really a new feature.

Also I think that they could make FreeCAD far more immediately impressive for even a modest FreeCAD user and hence make the software far more appealing. Even if we all know that the function has already been there for some time, most users do not.

Hence I thought it really should be implemented in 0.12, I mean would make it a far more impressive release.

But of course, I'll accept you decision if you think my perspective is out a bit on this matter.

Jim

yorik

2011-11-24 12:23

administrator   ~0001350

Yes it could, but I'd really like to enhance a bit the way it is now (allow different icons, integrate with the customize screen, etc...) So it's better to do that with more time

jmaustpc

2011-11-24 23:19

manager   ~0001351

OK Yorik, point taken and accepted. :-)

Honestly I wish I had thought of this months ago when there might have been time, but so be it.

:-)

Jim

yorik

2011-11-25 01:41

administrator   ~0001352

Don't worry, 0.12 is almost there now! As soon as J6urgen makes the break, we can start adding new stuff to the trunk...

yorik

2014-05-03 16:17

administrator   ~0004613

I think I'll cancel this item, since the whole world of FreeCAD macros is getting bigger, turning them into a menu would quickly become an insufficient solution, and certainly we need to think to something better (automatic macros download-and-install?). We definitely need to think this better.

In the meantime I'll remove the "macros" menu of the Draft module...

Related Changesets

FreeCAD: master 3c0c72e4

2014-08-07 16:07:22

yorik

Details Diff
Draft: removed macros menu - fixes 0000490

The macros menu code is on http://www.freecadweb.org/wiki/index.php?title=Macro_MacroMenu
Affected Issues
0000490
mod - src/Mod/Draft/CMakeLists.txt Diff File
mod - src/Mod/Draft/InitGui.py Diff File
rm - src/Mod/Draft/macros.py Diff File

Issue History

Date Modified Username Field Change
2011-11-23 06:38 jmaustpc New Issue
2011-11-24 01:02 yorik Note Added: 0001345
2011-11-24 01:03 yorik Status new => assigned
2011-11-24 01:03 yorik Assigned To => yorik
2011-11-24 01:03 yorik Target Version => 0.13
2011-11-24 01:17 yorik Priority normal => low
2011-11-24 08:45 jmaustpc Note Added: 0001349
2011-11-24 12:23 yorik Note Added: 0001350
2011-11-24 23:19 jmaustpc Note Added: 0001351
2011-11-25 01:41 yorik Note Added: 0001352
2012-05-05 18:51 yorik Summary Inbuilt scripts (macros) - better GUI access to for 0.12 => Inbuilt scripts (macros) - better GUI access
2012-09-16 16:30 yorik Target Version 0.13 => 0.14
2014-01-26 22:41 yorik Target Version 0.14 =>
2014-05-03 16:17 yorik Note Added: 0004613
2014-07-06 15:27 yorik Target Version => 0.15
2014-08-07 14:32 yorik Changeset attached => FreeCAD Master master 3c0c72e4
2014-08-07 14:32 yorik Status assigned => closed
2014-08-07 14:32 yorik Resolution open => fixed
2014-08-08 01:38 yorik Fixed in Version => 0.15