View Issue Details

IDProjectCategoryView StatusLast Update
0000048FreeCADBugpublic2010-05-22 23:04
ReporterunauthenticatedAssigned Toyorik 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionunable to reproduce 
Product Version0.8 
Target VersionFixed in Version 
Summary0000048: Freecad crash while trying to draw a line
DescriptionHi all,

when I was trying to draw a line after some playing with freecad 0.9 - revision 2646 (yes 0.9 and not 0.8 as it is stated in product version) program crashed with:

Coin warning in SbDPViewVolume::projectPointToLine(): invalid frustum
Coin warning in SbVec3f::setValue(): The double precision vector will not fit into a single precision vector.
Coin warning in SbVec3f::setValue(): The double precision vector will not fit into a single precision vector.
Pick first point:
Illegal storage access...


I am on ubuntu 9.10.
If you need more info please tell me how to get it.

Good luck
Peter
TagsNo tags attached.

Activities

yorik

2009-12-10 20:14

administrator   ~0000045

Hi Peter,
This and your other bug ( http://sourceforge.net/apps/mantisbt/free-cad/view.php?id=49 ) seem related, apparently both because of something going wrong with pivy, maybe a python version mismatch between freecad and pivy (I had that recently). Did you take your pivy package from the same location as the freecad package? Is your system 32bit or 64bit?

yorik

2009-12-12 14:50

administrator   ~0000049

This problem might be related to a not working OpenGL environment... Could you check for us the state of your opengl installation? Just put this in a terminal:

glxinfo

This should print a lot of info about the opengl driver... Basically if you could copy here the line that begin with:
direct rendering
OpenGL vendor string
OpenGL renderer string
OpenGL version string
OpenGL shading language version string

I think that could help us to figure out if you have 3D acceleration fully working.

unauthenticated

2009-12-12 16:09

viewer   ~0000050

hi,

yes I have taken it from the same location.

I have got 32bit system.

 28 OpenGL vendor string: Tungsten Graphics, Inc
 29 OpenGL renderer string: Mesa DRI Intel(R) 945GM GEM 20090712 2009Q2 RC3 x86/MMX/SSE2
 30 OpenGL version string: 1.4 Mesa 7.6
 31 OpenGL extensions:
 32 GL_ARB_copy_buffer, GL_ARB_depth_texture, GL_ARB_draw_buffers,
 33 GL_ARB_fragment_program, GL_ARB_half_float_pixel, GL_ARB_map_buffer_range,
 34 GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_pixel_buffer_object,
 35 GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow, GL_ARB_sync,
 36 GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
 37 GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
 38 GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
 39 GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
 40 GL_ARB_texture_non_power_of_two, GL_ARB_texture_rectangle,
 41 GL_ARB_transpose_matrix, GL_ARB_vertex_array_object,
 42 GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_window_pos,
 43 GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
 44 GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
 45 GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
 46 GL_EXT_cull_vertex, GL_EXT_compiled_vertex_array, GL_EXT_copy_texture,
 47 GL_EXT_draw_range_elements, GL_EXT_framebuffer_object,
 48 GL_EXT_framebuffer_blit, GL_EXT_fog_coord, GL_EXT_gpu_program_parameters,
 49 GL_EXT_multi_draw_arrays, GL_EXT_packed_depth_stencil,
 50 GL_EXT_packed_pixels, GL_EXT_pixel_buffer_object, GL_EXT_point_parameters,
 51 GL_EXT_polygon_offset, GL_EXT_provoking_vertex, GL_EXT_rescale_normal,
 52 GL_EXT_secondary_color, GL_EXT_separate_specular_color,
 53 GL_EXT_shadow_funcs, GL_EXT_stencil_two_side, GL_EXT_stencil_wrap,
 54 GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
 55 GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
 56 GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
 57 GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias,
 58 GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
 59 GL_3DFX_texture_compression_FXT1, GL_APPLE_client_storage,
 60 GL_APPLE_packed_pixels, GL_APPLE_vertex_array_object,
 61 GL_ATI_blend_equation_separate, GL_ATI_texture_env_combine3,
 62 GL_ATI_separate_stencil, GL_IBM_multimode_draw_arrays,
 63 GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat,
 64 GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
 65 GL_MESA_window_pos, GL_NV_blend_square, GL_NV_light_max_exponent,
 66 GL_NV_point_sprite, GL_NV_texture_env_combine4, GL_NV_texture_rectangle,
 67 GL_NV_texgen_reflection, GL_NV_vertex_program, GL_NV_vertex_program1_1,
 68 GL_OES_read_format, GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
 69 GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays

Hopefully it is enough.

Should I report more bugs on this forum? I see that it is possible to choose only 0.8 version and I am reporting for 0.9.

Best regards
Peter

yorik

2009-12-12 17:13

administrator   ~0000051

Okay, this indicates that you are running on software 3D (Mesa). There are other reports where FreeCAD fails when openGL is not working fine ( http://forum.freecadweb.org/viewtopic.php?f=4&t=187&start=10 ) but normally running 3D with mesa should work... We need to look a bit further.

If your computer has a good graphic chip (NVidia, ATI or Intel), maybe consider installing the corresponding driver, it will enhance much your 3D experience and probably solve this problem, but anyway we are investigating this issue.

Yes, please, if you find other bugs, reports will be welcome. No problem with the 0.8 number, actually for us it is more useful to know the revision number shown in the Help->About FreeCAD dialog and the system you are running...

yorik

2010-03-01 00:57

administrator   ~0000176

Hi, do you still get that error? I just ran FreeCAD without 3D acceleration (mesa only) and it works okay...

wmayer

2010-03-05 13:37

administrator   ~0000179

> Coin warning in SbDPViewVolume::projectPointToLine(): invalid frustum
I guess this could be one reason for a crash. If the frustum is empty then there may be no SoCamera node. Then, when trying to access the node in C++ without checking the pointer it crashes (but I'm not sure if we use it without checking before). From pivy side I don't know what the behaviour is.

yorik

2010-03-05 15:39

administrator   ~0000182

Anyway that might have changed completely, because now the draft module doesn't use sogui anymore to get the camera, so this bug might very well have gone away together, so unless we get more info, I'm not sure what we can do...

yorik

2010-05-22 23:04

administrator   ~0000220

closing due to lack of feedback. Please reopen if needed...

Issue History

Date Modified Username Field Change
2009-12-10 18:22 unauthenticated New Issue
2009-12-10 19:26 Jriegel Status new => assigned
2009-12-10 19:26 Jriegel Assigned To => yorik
2009-12-10 20:14 yorik Note Added: 0000045
2009-12-12 14:50 yorik Note Added: 0000049
2009-12-12 16:09 unauthenticated Note Added: 0000050
2009-12-12 17:13 yorik Note Added: 0000051
2010-03-01 00:57 yorik Note Added: 0000176
2010-03-05 13:37 wmayer Note Added: 0000179
2010-03-05 15:39 yorik Note Added: 0000182
2010-05-22 23:04 yorik Note Added: 0000220
2010-05-22 23:04 yorik Status assigned => closed
2010-05-22 23:04 yorik Resolution open => unable to reproduce