View Issue Details

IDProjectCategoryView StatusLast Update
0000453FreeCADBugpublic2014-10-27 13:06
ReporterwmayerAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.15Fixed in Version 
Summary0000453: Untranslated strings
Descriptionhttp://sourceforge.net/apps/phpbb/free-cad/viewtopic.php?f=10&t=1800
TagsNo tags attached.

Activities

yorik

2011-10-22 00:22

administrator   ~0001182

strings were extracted from source today and added to crowdin. I believe there will be not much missing until the 0.12 release...

wmayer

2011-10-22 12:13

administrator   ~0001185

http://forum.freecadweb.org/viewtopic.php?f=8&t=1234&sid=29f25110b85daf31d8a3d2ff19ae7c91&start=60#p11682

yorik

2011-10-24 13:05

administrator   ~0001188

A list of strings that are not considered by the translation system (from http://forum.freecadweb.org/viewtopic.php?f=10&t=1800&p=11798#p11778 )

View Window:

Unnamed (The project file name in the view tab)
Close tab (view tab close button)

Panels:

All the values name and valor (Display tab)
All the values name and valor (Data tab)

File Menu:

File type list (Dropdown list in file open dialog)
File type list (Dropdown list in file import dialog)
File type list (Dropdown list in merge project dialog)
Unknown (Project information -> Las modification date)
All the buttons and tooltips (Print Preview window)

Preferences window:

Dropdown module name list (General -> General -> Start group)
View smoothing (Part design)
Hint (Part design)

Edit Menu:

Buttons (Placements.. task panel)

View Menu:

Close (Texture mapping... task panel)
Display properties (Display properties window title)
display dropdown list (Display properties window)
Material dropdown list (Display properties window)
Workbenches (Workbench)
Sketcher geometries (Toolbars)

Tools Menu:

File type dropdown list (Save picture... window)
Cancel button (Save picture... window)

Help Menu:

Everything (Help)
Everything (About Qt)

Test framework:

Everything (Toolbar)
Everything (Test Command menu)
Inventor View (Menu)

Web:

Everything (Toolbar)

Sketcher:

Close button (Panel)
Help button (Panel)

Part Design:

Cancel button (Chamfer panel)

Part:

Close button (Boolean operation panel)
Apply button (Boolean operation panel)
Cancel button (Section panel)
Apply button (Section panel)
Cancel button (Extrude panel)
Apply button (Extrude panel)
Cancel button (Revolve panel)
Cancel button (Mirroring panel)
Cancel button (Fillet panel)
Shape info (Part menu)
Shape info (Status bar)

Robot:

Cancel button (Edge to trajectory panel)
Apply button (Edge to trajectory panel)
TaskEdge2TracParameter (Edge to trajectory panel)
Edges (Edge to trajectory panel)
Cluster (Edge to trajectory panel)

Mesh Design:

Evaluate & Repair Mesh (Evaluate & Repair Mesh panel title)

Inspection:

Everything (Inspection menu)
Everything (Visual inspection window)

yorik

2011-11-24 01:09

administrator   ~0001346

I'll assign this to myself... Not sure I can handle the untranslated strings, but I'll take care of updating and pulling the translations to/from crowdin.

yorik

2011-12-05 13:01

administrator   ~0001391

Since v012 is basically done, I changed issue priority and title from "Update translation for v0.12" to "Untranslated strings"

yorik

2014-09-18 15:00

administrator   ~0005126

Only points missing above where something should still be done:

1) The label of a default new document (Unnamed) should be translated. But this is decided in App, where Qt is not present. Not sure how to solve this... Werner do you have an idea about this?

2) The Web WB has no translations file. I'll take care of it...

wmayer

2014-09-18 16:44

administrator   ~0005127

Qt is already sparsely used in Base and App. But adding the whole translation system to App for just a couple of strings is overkill. So, I think we can keep it quite simple:

Put this into e.g. Gui/Document.cpp:
#if 0 // needed for Qt's lupdate utility
    qApp->translate("App::Document", "Unnamed");
#endif

Then inside Application::sNewDocument:
QString name = QCoreApplication::translate("App::Document", "Unnamed");
and if "usrName" there is not set from outside we can pass the translated string:
if (usrName)
  return GetApplication().newDocument(docName, usrName)->getPyObject();
else
  return GetApplication().newDocument(docName, name.toUtf8().constData())->getPyObject();

yorik

2014-09-18 23:21

administrator   ~0005129

Finally the fix was simple, the translation is already handled by the StdCmdNew command... I just made a little change, that is the document label is taken from the name passed to the command, not the unique name chosen by FreeCAD.

Related Changesets

FreeCAD: master 6e5fbc74

2014-09-18 17:24:16

yorik

Details Diff
Added base translation file for the Web WB - issue 0000453 Affected Issues
0000453
add - src/Mod/Web/Gui/Resources/translations/Web.ts Diff File
mod - src/Tools/updateTranslations.py Diff File

FreeCAD: master fbeb7beb

2014-09-19 01:17:50

yorik

Details Diff
Fixed label of document - fixes 0000453 Affected Issues
0000453
mod - src/App/Application.cpp Diff File

FreeCAD: master 429e55d7

2014-10-27 13:11:50

wmayer

Details Diff
+ make sure to set unique labels for newly created documents Affected Issues
0000453
mod - src/App/Application.cpp Diff File

Issue History

Date Modified Username Field Change
2011-10-21 09:32 wmayer New Issue
2011-10-22 00:22 yorik Note Added: 0001182
2011-10-22 12:13 wmayer Note Added: 0001185
2011-10-24 13:05 yorik Note Added: 0001188
2011-11-24 01:09 yorik Note Added: 0001346
2011-11-24 01:10 yorik Status new => assigned
2011-11-24 01:10 yorik Assigned To => yorik
2011-11-24 01:18 yorik Priority normal => urgent
2011-12-05 13:01 yorik Note Added: 0001391
2011-12-05 13:01 yorik Priority urgent => normal
2011-12-05 13:01 yorik Target Version => 0.13
2011-12-05 13:01 yorik Summary Update translation for v0.12 => Untranslated strings
2014-07-06 15:27 yorik Target Version 0.13 => 0.15
2014-09-18 15:00 yorik Note Added: 0005126
2014-09-18 15:50 yorik Changeset attached => FreeCAD Master master 6e5fbc74
2014-09-18 16:44 wmayer Note Added: 0005127
2014-09-18 23:21 yorik Note Added: 0005129
2014-09-18 23:30 yorik Changeset attached => FreeCAD Master master fbeb7beb
2014-09-18 23:30 yorik Status assigned => closed
2014-09-18 23:30 yorik Resolution open => fixed
2014-10-27 13:06 wmayer Changeset attached => FreeCAD Master master 429e55d7