View Issue Details

IDProjectCategoryView StatusLast Update
0000437SketcherFeaturepublic2014-01-26 22:39
Reportergalou_breizhAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.14 
Target VersionFixed in Version0.14 
Summary0000437: Sketcher: ask for value immediatly after creating a length constraint
DescriptionI think it would be practical to ask for a value immediately after creation of a constraint where a value is required.
For the moment, the constraint is created with the current value and the user has to double-click on the value to change it. Usually, the value is incorrect when the constraint is created and the user does want to modify it.
TagsNo tags attached.

Activities

logari81

2011-09-14 05:11

developer   ~0001065

I think the most common practice for creating a sketch is:

1. create all geometry entities
2. add necessary constraints to fully constrain the sketch
3. specify the correct dimensions (often iteratively)

in case the user wants to determine a dimension just after the creation of such a constraint he can easily double click on the dimension and do it. I don't think we have to bother the user with too many pop up dialogs, forcing him to follow a workflow possibly different from the one he prefers.

galou_breizh

2011-09-15 05:10

reporter   ~0001068

I just checked on CATIA, she actually behaves like FreeCAD. I just thought that if the user doesn't want to change the value, he/she can press the ENTER key. To avoid bothering the user we could also validate the current value if the user continues his/her work by clicking somewhere else.

Jriegel

2011-09-16 04:01

administrator   ~0001074

Mhh,
I'm not sure on this one. He is right mostly one create the dimension
and immediately change the value (at least I do often in CATIA).

I switch this to feedback and would like to here addition opinions...

galou_breizh

2011-09-30 06:41

reporter   ~0001137

A typical example usage is this excellent tutorial: http://www.youtube.com/watch?v=51CwhhXeG_c.
The dimensions are changed right after having created the constraint.

Maybe a checkable option could be created "ask for value upon constraint creation" or something in good English.

pperisin

2011-09-30 12:58

reporter   ~0001138

Hi,

maybe user can hold CTRL key while clicking on toolbar constraint icon. If he holds this key - dialog for dimesion appears (or vince-versa).

tilas

2011-11-01 11:44

reporter   ~0001205

another possibility would be - if the user starts pressing the number keys on the keyboard just after placing a dimension constraint - he is trying to modify the last dimension and not to rotate the view (current behavior)

momentumv5

2011-11-20 13:31

reporter   ~0001329

I think tilas' suggestion is very good, and a checkbox (like galou suggested) would also be good--allowing the user the option.

In SolidWorks, numerical constraints are like this: " I just thought that if the user doesn't want to change the value, he/she can press the ENTER key. To avoid bothering the user we could also validate the current value if the user continues his/her work by clicking somewhere else."

galou_breizh

2012-01-21 22:59

reporter   ~0001596

It looks to me that in many -most? - tutorials values are directly input after constraint creation: http://ubuntuone.com/3V0WEpY8JIejWP3EwzqtO2.

logari81

2012-01-22 08:42

developer   ~0001597

but in this tutorial he reproduces a sketch from an existing blueprint. He already knows the dimensions.

In general there will be two groups of users:
A. those who will want to enter the dimension just after the constraint
B. those that they want to enter dimension values later by iteratively trying values and checking how the sketch looks like.

If we don't ask for a dimension immediately after the constraint, the group A can just double click and enter the dimension.

If we ask for a dimension value then we make group A a little happier but group B much less happy because they will have to think about specific values instead of the general picture of the sketch.

normandc

2012-01-30 02:25

manager   ~0001606

Hey that's my video :D

In my current and past work, more than 90% of my modeling has been in the A scenario. I know what dimensions I want. I can't say about any other people, but I can't see the B scenario as being a specific group of exclusive users. I'm sure all users will find themselves in either "group" at one time or the other, and I have a feeling A would be more frequent (no proof of course).

Can't we just have both at the same time? Case in point: in Solid Edge, the dimension field is shown in the equivalent of FreeCAD's taskview instead of in a popup dialog. Right after adding a dim constraint, it is shown in the taskview, so you can enter a value; but you don't have to. Could we somehow have the dimension shown interactively right after you add the constraint, but if you select a new element it disappears?

djreichel

2012-04-01 18:54

reporter   ~0001842

the implementation of Autodesk Inventor allows the user to click on the dimension value after creating the dimension (or for that matter on any dimension when the operator is working in dimension mode) a dialog box prompting for dimension value is presented. This is a highly convenient, yet unobtrusive, way to supply dimension values.

FWIW, also dimensions can be given a name in this same dialog box, like Height= 22.5

Height will appear in a parameter table with the provided value.

Dimensions can also be set to the value of a pre-existing dimension by clicking on that existing dimension text while this dialog is opened.

A third utility provided by this dialog is the ability to simply enter a parameter name to provide the value for the newly created dimension.

pperisin

2012-04-02 07:05

reporter   ~0001849

Hi,

Maybe also AutoConstraints for length can be added, and work similar to what norm says solidEdge has. in Norm's suggestion there would be some menu that appears when you click on a length constraint, and you can input value here, or not (IMO best approach would be to use Draft command bar).

When you are placing polyline (or line), and have auto constraints on, you can have auto added horizontal or vertical constraints. How about making Draft Command bar active while placing line (or adding length constraints - or rotation or some other constraint), and in it you can input (but you do not have to) length, radius, angle....

Regards,
Petar

jrheinlaender

2013-01-18 13:50

developer   ~0002856

I implemented scenario A) see

https://github.com/jrheinlaender/FreeCAD/commit/4361cf8f26338e17350b95f215884fd31c391f9a

IMO users of scenario B) can just hit <Enter> when the dialog box pops up. I have the impression that these are the minority :-)

Should I make the automatic dialog box pop-up dependent on an option in the Preferences?

jrheinlaender

2013-01-18 13:57

developer   ~0002857

Reminder sent to: logari81

I implemented scenario A) see

https://github.com/jrheinlaender/FreeCAD/commit/4361cf8f26338e17350b95f215884fd31c391f9a [^]

IMO users of scenario B) can just hit <Enter> when the dialog box pops up. I have the impression that these are the minority :-)

Should I make the automatic dialog box pop-up dependent on an option in the Preferences?

Jriegel

2013-01-21 17:45

administrator   ~0002868

I have to say I'm also in the camp of drawing first and constraining later. Reproducing a Blue print is a nice Tutorial, but its not a design flow.
If you auto length, your sketch get very rigid from the start, and you can not move points and lines any more. Then the whole point of such a sketcher is muted....

But I can go with a preference entry which you can switch on that behavior.
But the default should be OFF!

normandc

2013-01-21 23:46

manager   ~0002869

Jriegel,

From what I understand, jrheinlander is not talking about inputing auto length constraints as you draw, only to pop up a dialog when you create a dimensional constraint. If you don't put constraints, your sketch remains flexible.

The idea is that when you want to apply constraints, it's to make your sketch rigid, and you know what dimension you want, so opening the dimension field dialog automatically saves the need to double-click on the dimension you just created.

And BTW this is how I work, even when I'm designing from scratch, and not following a blueprint. ;-)

jrheinlaender

2013-02-21 05:11

developer   ~0002931

How can we come to a consensus on this? Its a trivial addition to the code.

Jriegel

2013-02-21 16:15

administrator   ~0002935

I would say the following:
Standard behavior is insert the actual length of the object (as it is) and a option in the preferences (or Sketcher dialog) to ask immediately for a (new) value.

logari81

2013-02-21 17:29

developer   ~0002936

I will merge jrheinlaender's patch soon

logari81

2013-02-22 09:34

developer   ~0002938

ok, the fix is now in master. I think it is a bit of overkill to add a special preferences setting for this. Users that may want to add distance constraints and keep the default value, they can just press enter when the dialog pops up.

Issue History

Date Modified Username Field Change
2011-09-13 10:40 galou_breizh New Issue
2011-09-14 05:11 logari81 Note Added: 0001065
2011-09-15 05:10 galou_breizh Note Added: 0001068
2011-09-16 04:01 Jriegel Note Added: 0001074
2011-09-16 04:01 Jriegel Status new => feedback
2011-09-30 06:41 galou_breizh Note Added: 0001137
2011-09-30 12:58 pperisin Note Added: 0001138
2011-11-01 11:44 tilas Note Added: 0001205
2011-11-20 13:31 momentumv5 Note Added: 0001329
2012-01-21 22:59 galou_breizh Note Added: 0001596
2012-01-22 08:42 logari81 Note Added: 0001597
2012-01-30 02:25 normandc Note Added: 0001606
2012-04-01 18:54 djreichel Note Added: 0001842
2012-04-02 07:05 pperisin Note Added: 0001849
2012-05-05 17:50 yorik Project FreeCAD => Sketcher
2013-01-18 13:50 jrheinlaender Note Added: 0002856
2013-01-18 13:57 jrheinlaender Note Added: 0002857
2013-01-21 17:45 Jriegel Note Added: 0002868
2013-01-21 23:46 normandc Note Added: 0002869
2013-02-21 05:11 jrheinlaender Note Added: 0002931
2013-02-21 16:15 Jriegel Note Added: 0002935
2013-02-21 17:29 logari81 Note Added: 0002936
2013-02-22 09:34 logari81 Note Added: 0002938
2013-02-22 09:34 logari81 Status feedback => closed
2013-02-22 09:34 logari81 Resolution open => fixed
2013-02-22 09:34 logari81 Fixed in Version => trunk
2014-01-26 22:39 yorik Product Version trunk => 0.14
2014-01-26 22:39 yorik Fixed in Version trunk => 0.14