View Issue Details

IDProjectCategoryView StatusLast Update
0000436FreeCADFeaturepublic2011-09-17 06:58
ReporterunauthenticatedAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionno change required 
Product Versiontrunk 
Target VersionFixed in Version 
Summary0000436: 3D mouse navigation needs rethinking
DescriptionPan and Rotate motions (drag with middle/wheel button and left+middle/wheel, respectively) are quite difficult to perform with a mouse that has a sensitive wheel. The slightest motion of the wheel will start a zoom, which is not desired. Suggest adding left drag + modifier key as an alternative, or user configurable mouse mapping.
Additional InformationIn version 0.12, at least, the motions to pan and rotate are somewhat difficult and unergonomic; middle button drag to pan, and left+middle button drag to rotate. On a wheel mouse the wheel quite often doubles as the middle button, as the drawings indicate. However, depending on mouse, this can be extremely difficult, as it involves moving the mouse whilst keeping one finger depressed with a considerable force, yet perfectly motionless. If the finger on the wheel so much as nudges, it will start a zoom, which continues until an equivalent nudge is made in the other direction. This is bad ergonomics. The problem is a software design choice (button mapping) that collides with a hardware design choice (wheel sensitivity). The easiest and quickest remedy would be not to zoom while the middle button is down; even that would be an improvement.

The problem of 3D navigation has traditionally been solved with a modifier key that switches the drag motion (left button depressed) between pan and rotate(e.g. drag to pan, Ctrl+drag to rotate). Even better would be to let the users map the pan/zoom/rotate motions to their own mouse buttons.
TagsNo tags attached.

Activities

Jriegel

2011-09-16 03:54

administrator   ~0001072

If your wheel makes your middle mouse button unusable, you have a crappy
mouse.
We use the CATIA mouse mapping used by thousands of engineers around the
world. Get used to it!

wmayer

2011-09-17 06:58

administrator   ~0001107

There are alternative key/mouse combinations for CAD style without the need of a mouse wheel:
+ Rotating = SHIFT+RMB
+ Panning = CTRL+RMB
+ Zooming = SHIFT+CTRL+RMB

FYI: Using the LMB for the above is not possible because some of the combinations are used for multi-selection or might be reserved for other things.

IMO allowing to customize the combinations by the user leads only to more confusion. There I find the way better to choose between several styles that are hard-coded. You can choose between CAD, Inventor and Blender style.

Issue History

Date Modified Username Field Change
2011-09-11 21:22 unauthenticated New Issue
2011-09-16 03:54 Jriegel Note Added: 0001072
2011-09-17 06:58 wmayer Note Added: 0001107
2011-09-17 06:58 wmayer Status new => closed
2011-09-17 06:58 wmayer Resolution open => no change required