View Issue Details

IDProjectCategoryView StatusLast Update
0004223FreeCADBugpublic2019-12-15 15:26
Reporterrainbowhope Assigned To 
PrioritynoneSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSLinuxOS VersionDebian 10
Product Version0.18 
Target VersionFixed in Version 
Summary0004223: Does not generate codes by Z-coordinate
DescriptionHello! Created a detail representing a parallelepiped, with a barrel shape on the surface of the X-Y. In path layout I use "3D pocked". All paths are drawn, in the "G-code" emulation mode, the route of the cutter pressure is correct: the cutter moves both horizontally and vertically. Next, export to G-code FileName.tap and get a file in which the parameter Z contains the same values, either Z is missing from some string or naming. Z moves only at the beginning, for positioning to the starting point. As a result, the machine does not position the z axis, and instead of a barrel-shaped surface, a flat plane is obtained. If you ask milled recesses with a flat bottom, hole, Z otrabatyvaet fine. What am I doing wrong, or is it a bug ? I attach a project file and a file with G-codes.

OS: Debian GNU/Linux 10 (buster)
Word size of OS: 32-bit
Word size of FreeCAD: 32-bit
Version: 0.18.
Build type: Release
Python version: 2.7.16rc1
Qt version: 5.11.3
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Russian/Russia (ru_RU)

Richuto DSP A11 - CNC block.

A similar task made in ArtCAM machine fulfills correctly.
TagsNo tags attached.
FreeCAD Information<!--ATTENTION:
COMPLETELY ERASE THIS AFTER PASTING YOUR
Help > About FreeCAD > Copy to clipboard
NOTE: just the snippet alone will do without anything else included.
The ticket will not be submitted without it.
-->

Relationships

duplicate of 0004222 closed Path doesn't put Z values in g-code || Не формирует коды по Z-координате 

Activities

rainbowhope

2019-12-11 15:04

reporter  

Box_2.FCStd1 (21,158 bytes)
Box_2.tap (16,123 bytes)

Zolko

2019-12-13 16:08

reporter   ~0013908

This seems like a bogus bug report:

  • it's related to Path not to FreeCAD
  • it's not a crash, but an unwanted result

Issue History

Date Modified Username Field Change
2019-12-11 15:04 rainbowhope New Issue
2019-12-11 15:04 rainbowhope File Added: Box_2.FCStd1
2019-12-11 15:04 rainbowhope File Added: Box_2.tap
2019-12-13 16:00 DeepSOIC Relationship added related to 0004222
2019-12-13 16:00 DeepSOIC Relationship deleted related to 0004222
2019-12-13 16:00 DeepSOIC Relationship added duplicate of 0004222
2019-12-13 16:08 Zolko Note Added: 0013908
2019-12-15 15:26 openBrain Priority high => none
2019-12-15 15:26 openBrain Severity crash => major
2019-12-15 15:26 openBrain Status new => closed
2019-12-15 15:26 openBrain Resolution open => duplicate