View Issue Details

IDProjectCategoryView StatusLast Update
0004222FreeCADBugpublic2020-01-06 15:51
Reporterrainbowhope Assigned To 
PrioritylowSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformOSLinux Debian OS Version
Product Version0.18 
Target VersionFixed in Version 
Summary0004222: Path doesn't put Z values in g-code || Не формирует коды по Z-координате
DescriptionMade a box with barrel-like surface on x-y plane. I apply "3d pocket" the tool from Path workbench. All paths are rendered. In emulation mode, the trajectory is correct: the mill moves horizontally and vertically. Then, I export G-code as FileName.tap, and get a file with all Z coordinates at the same value, or missing Z vlues, ??or changes??. Z is moved only at the beggining, in the initial positioning. As a result, a flat surface is milled out, instead of the wanted barrel-like surface. If I mill pockets with planar floor, the pockets are milled correctly.

Is it me doing something wrong, or is it a bug?
Project and g-code files are attached.

Здравствуйте!
Создал деталь, представляющую параллелепипед, с бочковидной формой на поверхности Х-У.
В верстке Path использую "3D pocked". Все пути прорисовываются, в режиме эмуляции "G-code" маршрут давижения фрезы происходит корректно: фреза перемещается и по горизонтали и по вертикали. Далее, экспортирую в G-code FileName.tap и получаю файл, в котором параметр Z содержит одинаковые значения, либо Z отсутствует с какой-то строки, либо именения. Z перемещается лишь в начале, для позиционирования на начальную точку. Как следствие, станок не позиционирует ось Z, и вместо бочковидной поверхности получается ровная плоскость.
Если задаю фрезеровать углубления с ровным дном, отверстия, Z ртрабатывает нормально.
Что я делаю не так, или это баг ?
Прилагаю файл проекта и файл с G-кодами.

OS: Debian GNU/Linux 10 (buster)
Word size of OS: 32-bit
Word size of FreeCAD: 32-bit
Version: 0.18.
Build type: Release
Python version: 2.7.16rc1
Qt version: 5.11.3
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Russian/Russia (ru_RU)

Richuto DSP A11 A11S A11E 3 - Блок управления ЧПУ.

Аналогичную задачу, сделанную в ArtCAM станок отрабатывает правильно.
TagsNo tags attached.
FreeCAD Information<!--ATTENTION:
COMPLETELY ERASE THIS AFTER PASTING YOUR
Help > About FreeCAD > Copy to clipboard
NOTE: just the snippet alone will do without anything else included.
The ticket will not be submitted without it.
-->

Relationships

has duplicate 0004223 closed Does not generate codes by Z-coordinate 

Activities

rainbowhope

2019-12-11 13:51

reporter  

Box_2.FCStd1 (21,158 bytes)
Box_2.tap (16,123 bytes)

Kunda1

2019-12-11 20:17

administrator   ~0013903

@rainbowhope please do not open tickets unless they are vetted by the community first. Please read https://freecadweb.org/wiki/Tracker
Also tickets are to be created in the english language.

@DeepSOIC care to weigh in?

rainbowhope

2019-12-12 13:34

reporter   ~0013905

Hi,Kunda1 !
Please delete subjets: " Does not generate codes by Z-coordinate ".
The problem was resolved by increasing steps of Z-coordinate.

DeepSOIC

2019-12-13 16:05

developer   ~0013907

@Kunda1 I have translated the text to the best of my understanding. I'm not familiar with Path, so I can't really comment on the validity of the issue.

@rainbowhope created a duplicate, apparently by translating this one with machine translation. I've linked it as duplicate. I hope my translation is better.

"The problem was resolved by increasing steps of Z-coordinate." - apparently, @rainbowhope found out how to resolve the problem, and asks to close both tickets. I'm not sure though.

Kunda1

2020-01-06 15:51

administrator   ~0013990

Closing ticket

Issue History

Date Modified Username Field Change
2019-12-11 13:51 rainbowhope New Issue
2019-12-11 13:51 rainbowhope File Added: Box_2.FCStd1
2019-12-11 13:51 rainbowhope File Added: Box_2.tap
2019-12-11 20:17 Kunda1 Status new => feedback
2019-12-11 20:17 Kunda1 Note Added: 0013903
2019-12-12 13:34 rainbowhope Note Added: 0013905
2019-12-12 13:34 rainbowhope Status feedback => new
2019-12-13 15:59 DeepSOIC Summary Не формирует коды по Z-координате => Path doesn't put Z values in g-code || Не формирует коды по Z-координате
2019-12-13 15:59 DeepSOIC Description Updated View Revisions
2019-12-13 16:00 DeepSOIC Relationship added related to 0004223
2019-12-13 16:00 DeepSOIC Relationship deleted related to 0004223
2019-12-13 16:00 DeepSOIC Relationship added has duplicate 0004223
2019-12-13 16:05 DeepSOIC Note Added: 0013907
2019-12-15 15:27 openBrain Tag Attached: #tobeclosed
2019-12-15 15:27 openBrain Priority high => low
2019-12-15 15:27 openBrain Severity crash => major
2019-12-15 15:27 openBrain Status new => resolved
2019-12-15 15:27 openBrain Resolution open => no change required
2020-01-06 15:51 Kunda1 Tag Detached: #tobeclosed
2020-01-06 15:51 Kunda1 Status resolved => closed
2020-01-06 15:51 Kunda1 Note Added: 0013990