View Issue Details

IDProjectCategoryView StatusLast Update
0004206FreeCADBugpublic2019-11-26 21:55
Reporterotoien Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
PlatformLaptop PC with Nivida graphicsOSWindowsOS Version7
Product Version0.19 
Target VersionFixed in Version 
Summary0004206: Transparency display lost on multicolored object when reloading file
DescriptionAfter saving a file, next time it is reloaded display of transparency is sometimes lost on more complicated objects but not the transparency parameter. I have been able to isolate this to a the simple case of an extruded object with multicolored faces where transparency display is always lost on file load.

It was tested with latest development version on Win7, but I have experienced these problems for a long time, also in stable ver. 0.18). It was confirmed by two forum member using Windows 10:
Link to discussion thread in Help forum
Steps To Reproduce1. Create a simple shape, for instance a rectangle and extrude it. Mark it and apply transparency under the view tab, for instance set it to 80% and observe correct display. Save and close file. Reload it and observe correct display of transparency.

2a. Mark object, right click, Set Colors, mark one of the faces and change color. Keep transparency. Transparency is still correctly displayed. Save file and close it. Reload file. Observe transparency display gone but color is correct, and on inspection the transparency parameter under the view tab is still at 80%.

2b. Close file without saving and reload again (transparency gone). Mark object and change color so that it gets a single color. Transparency is back again. Save file, close and reload. Transparency is now correct.

2c. Close file without saving and reload again (transparency gone). Change transparency (for instance to 81%). Observe correct transparency being displayed again. Save, close and reload. Transparency display is gone again.

The attached files show the results of the different tests 2a to 2c above.
Additional InformationCould the problems be related to this fairly recent change that can allow per face transparency to be set?
Link to per face transparency forum thread

Forum member wmayer in that thread noted that "The problem might be that the Transparency property was designed to affect the whole object and the possibility to set transparent color per face was added much later. So, it seems that the order of reading in the properties from the project matters."
Tagscolors, transparency
FreeCAD InformationOS: Windows 7 SP 1 (6.1)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.18760 (Git)
Build type: Release
Branch: master
Hash: ef73ab5f3a330d3c44138f23290f8c9f7a334caf
Python version: 3.6.7
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/United States (en_US)

(For the record I am using a Nivida graphics card)

Activities

otoien

2019-11-26 21:54

reporter  

Transparency-test001a.FCStd (5,465 bytes)
Transparency-test001b.FCStd (5,464 bytes)
Transparency-test001c.FCStd (5,462 bytes)

Issue History

Date Modified Username Field Change
2019-11-26 21:54 otoien New Issue
2019-11-26 21:54 otoien Tag Attached: colors
2019-11-26 21:54 otoien Tag Attached: transparency
2019-11-26 21:55 otoien File Added: Transparency-test001a.FCStd
2019-11-26 21:55 otoien File Added: Transparency-test001b.FCStd
2019-11-26 21:55 otoien File Added: Transparency-test001c.FCStd