View Issue Details

IDProjectCategoryView StatusLast Update
0004195FreeCADBugpublic2020-01-10 20:46
ReporterXwang Assigned Towmayer  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target Version0.19Fixed in Version0.19 
Summary0004195: Python 3.8 Compatibility incl. Shiboken/Pyside (was: Unable to use addon manager)
DescriptionWhen I try to use the addon manager nothin happens and the following message appers on the console from which I have opened freecad:
Running the Python command 'Std_AddonMgr' failed:
Traceback (most recent call last):
  File "/usr/lib/freecad/Mod/AddonManager/AddonManagerGui.py", line 10, in Activated
    import AddonManager
  File "/usr/lib/freecad/Mod/AddonManager/AddonManager.py", line 52, in <module>
    import urllib.request as urllib2
  File "/usr/lib/python3.8/urllib/request.py", line 88, in <module>
    import http.client
  File "/usr/lib/python3.8/http/__init__.py", line 5, in <module>
    class HTTPStatus(IntEnum):
  File "/usr/lib/python3.8/enum.py", line 164, in __new__
    enum_class = super().__new__(metacls, cls, bases, classdict)

'Shiboken.ObjectType' object is not iterable
Steps To Reproduce1)Open Freecad from a console
2)Click on addon manager
3)Look at the console output
Tags#pending-forum, #tobeclosed, 0.18, addon-manager
FreeCAD InformationOS: Arch Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16148 (Git)
Build type: Release
Branch: makepkg
Hash: 9c2cf7283bc71107202e63b9d8cd0b7eb8c0e531
Python version: 3.8.0
Qt version: 5.13.2
Coin version: 4.0.0a
OCC version: 7.4.0
Locale: Italian/Italy (it_IT)

Relationships

related to 0004229 assigned Compilation fails with PySide2 5.14: PYSIDE2RCCBINARY missing 

Activities

openBrain

2019-11-22 16:52

developer   ~0013832

@Xwang : thanks for reporting. However according to our guidelines (big yellow box), could you please open a thread on our forum and crosslink it with this ticket ? You'll get more visibility & help there.
Also trying to reproduce with latest 0.19 dev version will be great.

openBrain

2019-11-23 11:28

developer   ~0013836

Forum topic opened by reporter

Kunda1

2019-11-25 11:09

administrator   ~0013843

It's a python 3.8 / pyside2 / shiboken compatibility issue. See https://forum.freecadweb.org/viewtopic.php?f=4&t=40986&p=348123#p348079

Kunda1

2019-12-05 14:05

administrator   ~0013865

Per @Xwang in https://forum.freecadweb.org/viewtopic.php?f=3&t=41119#p349607

I have installed the 0.18 appimage from this https://aur.archlinux.org/packages/freecad-appimage/ and it does not have the issue, so it seems related to the compilation of the package (previously I had this package https://aur.archlinux.org/packages/freecad/).

Xwang

Kunda1

2019-12-05 14:10

administrator   ~0013866

Renamed ticket

lonaowna

2019-12-19 17:09

reporter   ~0013933

Last edited: 2019-12-19 17:13

View 2 revisions

So PySide2 5.14 (with Python 3.8 support) was released today, but it introduces a new problem: 0004229

Kunda1

2019-12-29 13:32

administrator   ~0013950

a user reported this fixed now: https://forum.freecadweb.org/viewtopic.php?f=4&t=40986&p=356544#p356544

Kunda1

2020-01-07 17:13

administrator   ~0014012

Last edited: 2020-01-09 18:59

View 2 revisions

This ticket depends on 0004229
Please test once it is fixed

howetuft

2020-01-09 13:36

reporter   ~0014029

Last edited: 2020-01-09 18:59

View 2 revisions

I recompiled 'master' branch this night under Arch Linux and everything went well for me: neither "'Shiboken.ObjectType' object is not iterable" nor "PYSIDE2RCCBINARY missing" (0004229) any more.
I hope it's ok for other Arch users as well - may other reporters confirm?

Kunda1

2020-01-09 19:01

administrator   ~0014031

@Xwang can u confirm issue is fixed?

Xwang

2020-01-09 23:07

reporter   ~0014035

Yes. The issue seems to be fixed now.
Thank you very much!!!

Kunda1

2020-01-10 20:46

administrator   ~0014037

Thanks. Closing ticket

Issue History

Date Modified Username Field Change
2019-11-18 18:41 Xwang New Issue
2019-11-18 18:41 Xwang Tag Attached: 0.18
2019-11-18 18:41 Xwang Tag Attached: addon-manager
2019-11-22 16:52 openBrain Note Added: 0013832
2019-11-22 16:53 openBrain Tag Attached: #post-to-forum
2019-11-22 16:53 openBrain Status new => feedback
2019-11-23 11:28 openBrain Note Added: 0013836
2019-11-23 11:28 openBrain Tag Detached: #post-to-forum
2019-11-23 11:28 openBrain Tag Attached: #pending-forum
2019-11-25 11:09 Kunda1 Note Added: 0013843
2019-12-05 14:03 Kunda1 Summary Unable to use addon manager => Unable to use addon manager (python 3.8/shiboken/pyside issue)
2019-12-05 14:05 Kunda1 Note Added: 0013865
2019-12-05 14:05 Kunda1 Status feedback => confirmed
2019-12-05 14:05 Kunda1 Target Version => 0.19
2019-12-05 14:10 Kunda1 Summary Unable to use addon manager (python 3.8/shiboken/pyside issue) => Python 3.8 Compatibility incl. Shiboken/Pyside (was: Unable to use addon manager)
2019-12-05 14:10 Kunda1 Note Added: 0013866
2019-12-19 17:09 lonaowna Note Added: 0013933
2019-12-19 17:13 lonaowna Note Edited: 0013933 View Revisions
2019-12-29 13:32 Kunda1 Note Added: 0013950
2019-12-29 13:32 Kunda1 Tag Attached: #tobeclosed
2020-01-07 17:08 Kunda1 Relationship added related to 0004229
2020-01-07 17:13 Kunda1 Note Added: 0014012
2020-01-09 13:36 howetuft Note Added: 0014029
2020-01-09 18:59 Kunda1 Note View State: 0014029: private
2020-01-09 18:59 Kunda1 Note View State: 0014029: public
2020-01-09 18:59 Kunda1 Note Edited: 0014029 View Revisions
2020-01-09 18:59 Kunda1 Note Edited: 0014012 View Revisions
2020-01-09 19:01 Kunda1 Status confirmed => feedback
2020-01-09 19:01 Kunda1 Note Added: 0014031
2020-01-09 23:07 Xwang Note Added: 0014035
2020-01-09 23:07 Xwang Status feedback => new
2020-01-10 20:46 Kunda1 Assigned To => wmayer
2020-01-10 20:46 Kunda1 Status new => closed
2020-01-10 20:46 Kunda1 Resolution open => fixed
2020-01-10 20:46 Kunda1 Fixed in Version => 0.19
2020-01-10 20:46 Kunda1 Note Added: 0014037