View Issue Details

IDProjectCategoryView StatusLast Update
0004153DraftBugpublic2019-10-10 12:55
Reporterwandererfan Assigned Towandererfan  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformWindowsOSOS Version
Product Version0.19 
Target Version0.19Fixed in Version0.19 
Summary0004153: "Not authorized to open this file" in Draft Preferences on Windows
DescriptionForum discussion
When attempting to pick a default ShapeString font in Draft Preferences, Windows users receive file permission error.

Does not occur on Linux (or OSX?).
Steps To Reproducesee Forum discussion
Additional Informationnote similarities with 0004085.
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0004085 closedwandererfan TechDraw Fail on PropertyFileIncluded Rename (Windows only?) 

Activities

wandererfan

2019-10-04 23:39

manager   ~0013711

Access to the Windows font folder seems to be generally problematic:

https://www.experts-exchange.com/questions/29139381/Windows-10-Font-Folder-nightmare.html
https://www.makeuseof.com/tag/fix-access-denied-folders-windows-10/
https://community.spiceworks.com/topic/185037-remove-admin-requirements-for-user-font-installation

wandererfan

2019-10-04 23:39

manager   ~0013712

This is not actually related to 4085. Separate issues entirely.

wandererfan

2019-10-04 23:42

manager   ~0013713

An easy work around is to copy the font files to a directory to which the user has rights.

wandererfan

2019-10-05 02:02

manager   ~0013714

This batch file fixes the problem. Run as administrator.

attrib -r -s "c:\windows\fonts"
takeown /f "c:\windows\fonts"
icacls "c:\windows\fonts" /t /grant "authenticated users":(OI)(CI)F

From here.

wandererfan

2019-10-05 02:03

manager   ~0013715

not a FreeCAD problem.

wandererfan

2019-10-10 12:55

manager   ~0013735

adding parameter "DontUseNativeDialog" (true) to BaseApp/Preferences/Dialog allows access to the Windows/Fonts folder.

Dialog appearance will be slightly altered.

Issue History

Date Modified Username Field Change
2019-10-03 13:36 wandererfan New Issue
2019-10-03 13:37 wandererfan Relationship added related to 0004085
2019-10-04 23:39 wandererfan Note Added: 0013711
2019-10-04 23:39 wandererfan Note Added: 0013712
2019-10-04 23:42 wandererfan Note Added: 0013713
2019-10-05 02:02 wandererfan Note Added: 0013714
2019-10-05 02:03 wandererfan Assigned To => wandererfan
2019-10-05 02:03 wandererfan Status new => resolved
2019-10-05 02:03 wandererfan Resolution open => fixed
2019-10-05 02:03 wandererfan Fixed in Version => 0.19
2019-10-05 02:03 wandererfan Note Added: 0013715
2019-10-10 12:55 wandererfan Note Added: 0013735