View Issue Details

IDProjectCategoryView StatusLast Update
0004131FreeCADBugpublic2019-09-20 23:36
Reportertbray Assigned Towandererfan  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows 10 OS Version8109
Product Version0.18 
Target Version0.19Fixed in Version0.19 
Summary0004131: Import spreadsheet into TechDraw, looses properties
DescriptionThe spreadsheet has a nice feature that allows display values in inches. If you use this feature, add it to a TechDrawing, or export it, the property is lost and everything reverts back to the standard mm setting (regardless of the General "units" setting.
Steps To ReproduceMake a simple drawing using a sketch, constrain it and Pad it.
Make a spreadsheet and import the 3 dimensions.
Make a 2 copies of the 3 dimensions. Change the properties of the first set to "in". The second set divide each value by 25.4 (mm -> in).
The two sets of values should pretty much agree, the last set will have more decimal places.
Import the spreadsheet into a TechDraw.
The values with the "in" view property will change back to mm.
Additional InformationOS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16131 (Git)
Build type: Release
Branch: releases/FreeCAD-0-18
Hash: 3129ae4296e40ed20e7b3d460b86e6969acbe1c3
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)
Tagsspreadsheet, TechDraw
FreeCAD Information

Activities

tbray

2019-09-16 18:49

reporter  

SSdemo.zip (23,841 bytes)

tbray

2019-09-16 18:55

reporter   ~0013610

Why is this an issue:
I often draw stuff that are based on metric units and if I print them it isn't an issue. If I make them on my mill which is manual and uses English/American measurements, I need to build a cut list manually. I can do it in the spreadsheet but its ugly, especially because I have to use the mm to in manually, and the spreadsheet still says mm.

It would actually be better to just be able to turn off the dimensions on a cell by cell basis but I would prefer to use the "in" property.

wandererfan

2019-09-19 15:20

manager   ~0013649

Last edited: 2019-09-19 15:22

View 2 revisions

confirmed.

wandererfan

2019-09-19 15:24

manager   ~0013650

I think this is the result you're looking for:

SSdemo.png (29,806 bytes)
SSdemo.png (29,806 bytes)

wandererfan

2019-09-20 23:35

manager   ~0013668

Should be fixed bycommit 019198a30c.

Issue History

Date Modified Username Field Change
2019-09-16 18:49 tbray New Issue
2019-09-16 18:49 tbray File Added: SSdemo.zip
2019-09-16 18:50 tbray Tag Attached: spreadsheet
2019-09-16 18:50 tbray Tag Attached: TechDraw
2019-09-16 18:55 tbray Note Added: 0013610
2019-09-19 15:20 wandererfan Assigned To => wandererfan
2019-09-19 15:20 wandererfan Status new => confirmed
2019-09-19 15:20 wandererfan Target Version => 0.19
2019-09-19 15:20 wandererfan Steps to Reproduce Updated View Revisions
2019-09-19 15:20 wandererfan Additional Information Updated View Revisions
2019-09-19 15:20 wandererfan Note Added: 0013649
2019-09-19 15:22 wandererfan Note Edited: 0013649 View Revisions
2019-09-19 15:24 wandererfan File Added: SSdemo.png
2019-09-19 15:24 wandererfan Note Added: 0013650
2019-09-20 23:35 wandererfan Note Added: 0013668
2019-09-20 23:36 wandererfan Status confirmed => resolved
2019-09-20 23:36 wandererfan Resolution open => fixed
2019-09-20 23:36 wandererfan Fixed in Version => 0.19