View Issue Details

IDProjectCategoryView StatusLast Update
0004092ArchBugpublic2019-09-01 16:21
Reporterpscheich Assigned Toberndhahnebach  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.19 
Target VersionFixed in Version0.19 
Summary0004092: Ubuntu-FreeCAD-Daily ifc_contexts_IFC4.json is missing
DescriptionHey,
ifc_contexts_IFC4.json is missing in dir /usr/share/freecad-daily/Mod/Arch/Presets/.

% ls -lh /usr/share/freecad-daily/Mod/Arch/Presets/
total 512K
-rw-r--r-- 1 root root 6,9K Aug 19 01:55 ifc_products_IFC2X3.json
-rw-r--r-- 1 root root 372K Aug 19 01:55 ifc_products_IFC4.json
-rw-r--r-- 1 root root 754 Aug 19 01:55 ifc_types_IFC2X3.json
-rw-r--r-- 1 root root 15K Aug 19 01:55 ifc_types_IFC4.json
-rw-r--r-- 1 root root 35K Aug 19 01:55 profiles.csv
-rw-r--r-- 1 root root 76K Aug 19 01:55 pset_definitions.csv




% freecad-daily
FreeCAD 0.19, Libs: 0.19R
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##

connect failed: No such file or directory
[Errno 2] No such file or directory: '/usr/share/freecad-daily/Mod/Arch/Presets/ifc_contexts_IFC4.json'
Traceback (most recent call last):
  File "<string>", line 32, in Initialize
  File "/usr/share/freecad-daily/Mod/Arch/Arch.py", line 43, in <module>
    from ArchWall import *
  File "/usr/share/freecad-daily/Mod/Arch/ArchWall.py", line 24, in <module>
    import FreeCAD,Draft,ArchComponent,DraftVecUtils,ArchCommands,math
  File "/usr/share/freecad-daily/Mod/Arch/ArchComponent.py", line 28, in <module>
    import FreeCAD,Draft,ArchCommands,math,sys,json,os,ArchIFC,ArchIFCSchema
  File "/usr/share/freecad-daily/Mod/Arch/ArchIFC.py", line 11, in <module>
    import ArchIFCSchema
  File "/usr/share/freecad-daily/Mod/Arch/ArchIFCSchema.py", line 7, in <module>
    "ifc_contexts_" + IfcVersion + ".json")) as f:



Steps To ReproduceStarting FreeCad -> Change Workbench to Arch -> This Error occurs.
[[Errno 2] No such file or directory: '/usr/share/freecad-daily/Mod/Arch/Presets/ifc_contexts_IFC4.json']
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0004110 closedkkremitzki No such file or directory: '/usr/share/freecad-daily/Mod/Arch/Presets/ifc_contexts_IFC4.jso (duplicate of closed ticket 0004092) 

Activities

pscheich

2019-08-19 13:11

reporter   ~0013430

I'm using Ubuntu 19.04.

Kunda1

2019-08-19 22:59

administrator   ~0013432

@pschelch thank you for the ticket AND please follow our guidelines (big yellow banner at top of the page).
Relevant forum thread: https://forum.freecadweb.org/viewtopic.php?f=39&t=38651&p=327886#p327865

berndhahnebach

2019-08-20 11:36

developer   ~0013433

fixed:
https://github.com/FreeCAD/FreeCAD/commit/bdfdf77ffcfce934834a0f3a30d9c566dbd0e676

Kunda1

2019-08-21 19:57

administrator   ~0013443

@berndhahnebach Thanks. JFYI, Please make sure you specify the relevant version of FC this was fixed in (in this case 0.19). I needed to add it manually after you closed it.

Related Changesets

FreeCAD: master bdfdf77f

2019-08-19 11:02:53

Moult


Committer: berndhahnebach Details Diff
Add contexts file for IFC2X3 Affected Issues
0004092
mod - src/Mod/Arch/ArchIFCSchema.py Diff File
mod - src/Mod/Arch/CMakeLists.txt Diff File
add - src/Mod/Arch/Presets/ifc_contexts_IFC2X3.json Diff File

FreeCAD: master ad4f4f07

2019-08-19 11:30:24

Moult


Committer: berndhahnebach Details Diff
Convert old json files to include more metadata as per IFC4 standard Affected Issues
0004092
mod - src/Mod/Arch/Presets/ifc_products_IFC2X3.json Diff File
mod - src/Mod/Arch/Presets/ifc_types_IFC2X3.json Diff File

Issue History

Date Modified Username Field Change
2019-08-19 13:08 pscheich New Issue
2019-08-19 13:11 pscheich Note Added: 0013430
2019-08-19 22:59 Kunda1 Note Added: 0013432
2019-08-20 11:36 berndhahnebach Assigned To => berndhahnebach
2019-08-20 11:36 berndhahnebach Status new => closed
2019-08-20 11:36 berndhahnebach Resolution open => fixed
2019-08-20 11:36 berndhahnebach Note Added: 0013433
2019-08-21 19:56 Kunda1 Changeset attached => FreeCAD master bdfdf77f
2019-08-21 19:56 Kunda1 Changeset attached => FreeCAD master ad4f4f07
2019-08-21 19:57 Kunda1 Note Added: 0013443
2019-08-21 19:58 Kunda1 Fixed in Version => 0.19
2019-09-01 16:21 Kunda1 Relationship added related to 0004110