View Issue Details

IDProjectCategoryView StatusLast Update
0004017TechDraw[FreeCAD] Bugpublic2019-07-20 15:15
ReporterTomasBerghAssigned Towandererfan 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.18 
Target VersionFixed in Version 
Summary0004017: Freecad hangs when editing non valid value in data-field
DescriptionHello,
In the Hatch command if applying a faulty value to the Hatch scale Freecad hangs.
Maybe the value should be evaluated before Freecad applies it?

OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16093 (Git)
Build type: Release
Branch: releases/FreeCAD-0-18
Hash: 690774c0effe4fd7b8d2b5e2fb2b8c8d145e21ce
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Swedish/Sweden (sv_SE)

BR
Tomas Bergh
TagsNo tags attached.

Activities

openBrain

2019-06-13 19:07

developer   ~0013203

@TomasBergh thanks for reporting.
May you please try with latest release ? Your version is a bit outdated.
Also please could you first open a topic in the Help forum to discuss and confirm your issue ? Especially provide a detailed step-by-step process to reproduce.
Bug reporting process is explained in the giant yellow header of this page (shortly), in the link in the banner, and in "Read this before reporting" at left side of the page. ;)

TomasBergh

2019-06-14 06:29

reporter   ~0013210

Last edited: 2019-06-14 06:30

View 2 revisions

Hi,
Sorry, I thought it wasn't long ago since I reinstalled FC.
Sorry again, it is allways a battle against time, I should have gone to the forum first.

How to get the latest version with the settings to remain? Will the installer just update the necessary files?

BR
Tomas

wandererfan

2019-07-19 15:01

manager   ~0013366

Fix committed to master branch.

wandererfan

2019-07-20 15:15

manager   ~0013372

Fix committed to releases/FreeCAD-0-18 branch.

Related Changesets

FreeCAD: master 21efae34

2019-07-19 00:12:28

wandererfan

Details Diff
[TD]Fix 0004017 Crash on bad hatch scale Affected Issues
0004017
mod - src/Mod/TechDraw/Gui/QGIFace.cpp Diff File
mod - src/Mod/TechDraw/Gui/QGIFace.h Diff File
mod - src/Mod/TechDraw/Gui/QGIViewPart.cpp Diff File
mod - src/Mod/TechDraw/Gui/ViewProviderHatch.cpp Diff File

FreeCAD: releases/FreeCAD-0-18 7320c4c4

2019-07-19 00:12:28

wandererfan

Details Diff
[TD]Fix 0004017 Crash on bad hatch scale Affected Issues
0004017
mod - src/Mod/TechDraw/Gui/QGIFace.cpp Diff File
mod - src/Mod/TechDraw/Gui/QGIFace.h Diff File
mod - src/Mod/TechDraw/Gui/QGIViewPart.cpp Diff File
mod - src/Mod/TechDraw/Gui/ViewProviderHatch.cpp Diff File

Issue History

Date Modified Username Field Change
2019-06-13 06:39 TomasBergh New Issue
2019-06-13 19:07 openBrain Note Added: 0013203
2019-06-14 06:29 TomasBergh Note Added: 0013210
2019-06-14 06:30 TomasBergh Note Edited: 0013210 View Revisions
2019-06-14 16:32 Kunda1 Status new => feedback
2019-07-19 15:01 wandererfan Changeset attached => FreeCAD master 21efae34
2019-07-19 15:01 wandererfan Note Added: 0013366
2019-07-19 15:01 wandererfan Assigned To => wandererfan
2019-07-19 15:01 wandererfan Status feedback => closed
2019-07-19 15:01 wandererfan Resolution open => fixed
2019-07-20 15:15 wandererfan Changeset attached => FreeCAD releases/FreeCAD-0-18 7320c4c4
2019-07-20 15:15 wandererfan Note Added: 0013372