View Issue Details

IDProjectCategoryView StatusLast Update
0004015Expressions[FreeCAD] Bugpublic2020-01-06 16:38
ReporteropenBrain Assigned Towmayer  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.18 
Target VersionFixed in Version[FreeCAD] 0.19 
Summary0004015: Expression "jumps" to new object when created
DescriptionAn expression using an object referrer can inappropriately "jump" to a new object when this latter is created.
From first investigations, it happens only if referrer is the object label, not if it is its (internal) name.
---
Forum thread
Steps To ReproduceFrom a blank new design :
  1. Go to Part WB and create a cube => Will be labeled "Cube" in the tree view
  2. Add a second cube (=> Will be labeled "Cube001" in the tree view) then set its Z position as being "Cube.Length"
  3. Add a third cube (=> Will be labeled "Cube002") ==> Ouch ! FreeCAD immediately complains about a cyclic dependency. If you look back at Cube001 properties, its Z position has "jumped" to Cube002.Length instead of Cube.Length
--- It doesn't happen if internal name is used in expression (i.e. Box.Length instead of Cube.Length), but FreeCAD however complains about a cyclic dependency.
Additional Information
OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.1.
Build type: Release
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)
and
OS: Ubuntu 18.04.2 LTS (KDE/plasma)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19. (2019/06/09)
Build type: Release
Python version: 3.6.7
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)
Tagsexpressions
FreeCAD Information

Activities

ezzieyguywuf

2019-12-03 04:33

developer   ~0013859

I cannot reproduce this error using the FreeCAD version below - is this resolved?

OS: Gentoo/Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.18787 (Git)
Build type: Debug
Branch: master
Hash: 9898f3b242bec84396ee30a5722f8c462223e612
Python version: 3.6.5
Qt version: 5.12.4
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/United States (en_US)

openBrain

2019-12-17 12:23

developer   ~0013931

@ezzieyguywuf : I can't no longer reproduce it. Maybe the 'Big Merge' solved this.
Anyway, I'll tag ticket to be closed.

Kunda1

2020-01-06 16:38

administrator   ~0014003

Closing

Issue History

Date Modified Username Field Change
2019-06-10 18:14 openBrain New Issue
2019-06-10 18:14 openBrain Tag Attached: expressions
2019-06-12 14:19 wmayer Status new => confirmed
2019-12-03 04:33 ezzieyguywuf Note Added: 0013859
2019-12-17 12:23 openBrain Note Added: 0013931
2019-12-17 12:23 openBrain Tag Attached: #tobeclosed
2019-12-17 12:24 openBrain Status confirmed => resolved
2019-12-17 12:24 openBrain Resolution open => fixed
2020-01-06 16:37 Kunda1 Tag Detached: #tobeclosed
2020-01-06 16:38 Kunda1 Assigned To => wmayer
2020-01-06 16:38 Kunda1 Status resolved => closed
2020-01-06 16:38 Kunda1 Fixed in Version => 0.19
2020-01-06 16:38 Kunda1 Note Added: 0014003