View Issue Details

IDProjectCategoryView StatusLast Update
0004010Part[FreeCAD] Bugpublic2019-06-13 04:10
ReporterfonteAssigned Towmayer 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformHP probookOSubuntuOS Version 18.04
Product Version[FreeCAD] 0.18 
Target VersionFixed in Version[FreeCAD] 0.19 
Summary0004010: Box Selection + Part -> MakeCompound will crash FreeCAD
DescriptionBox Selection of the visible components in the attached file + Part -> MakeCompound will crash FreeCAD
Additional InformationProgram received signal SIGSEGV, Segmentation fault.
#0 /lib/x86_64-linux-gnu/libc.so.6(+0x3ef20) [0x7fb30684cf20]
#1 0x7fb2529b855b in NCollection_BaseMap::Destroy(void (*)(NCollection_ListNode*, opencascade::handle<NCollection_BaseAllocator>&), bool) from /tmp/.mount_FreeCA4MX3xs/usr/lib/./libTKernel.so.7+0x4b
0000002 0x7fb23dcdf907 in PartGui::ViewProviderCompound::updateData(App::Property const*) from /tmp/.mount_FreeCA4MX3xs/usr/lib/PartGui.so+0x727
0000003 0x7fb30ce86a4f in Gui::ViewProvider::update(App::Property const*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADGui.so+0x5f
0000004 0x7fb30cc1f28f in Gui::Document::slotChangedObject(App::DocumentObject const&, App::Property const&) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADGui.so+0x2f
0000005 0x7fb30c49cc96 in boost::signals2::detail::signal_impl<void (App::DocumentObject const&, App::Property const&), boost::signals2::optional_last_value<void>, int, std::less<int>, boost::function<void (App::DocumentObject const&, App::Property const&)>, boost::function<void (boost::signals2::connection const&, App::DocumentObject const&, App::Property const&)>, boost::signals2::mutex>::operator()(App::DocumentObject const&, App::Property const&) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADApp.so+0x1f6
0000006 0x7fb30c4a98f1 in App::DocumentObject::onChanged(App::Property const*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADApp.so+0x21
0000007 0x7fb2697ea0ec in Part::Feature::onChanged(App::Property const*) from /tmp/.mount_FreeCA4MX3xs/usr/lib/Part.so+0x3c
0000008 0x7fb30c521b49 in App::Property::touch() from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADApp.so+0x19
0000009 0x7fb2697d6480 in Part::Compound::execute() from /tmp/.mount_FreeCA4MX3xs/usr/lib/Part.so+0x6e0
0000010 0x7fb30c4a783d in App::DocumentObject::recompute() from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADApp.so+0x8d
0000011 0x7fb2697ea00b in Part::Feature::recompute() from /tmp/.mount_FreeCA4MX3xs/usr/lib/Part.so+0xb
0000012 0x7fb30c468d2c in App::Document::_recomputeFeature(App::DocumentObject*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADApp.so+0x9c
0000013 0x7fb30c46d271 in App::Document::recompute() from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADApp.so+0x1e1
0000014 0x7fb30c4d93c4 in App::DocumentPy::recompute(_object*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADApp.so+0x34
0000015 0x7fb30c4d94f7 in App::DocumentPy::staticCallback_recompute(_object*, _object*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADApp.so+0x27
0000016 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libpython3.6m.so.1.0(_PyCFunction_FastCallDict+0x18e) [0x7fb30bafbc1e]
0000017 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libpython3.6m.so.1.0(+0x1650da) [0x7fb30bb950da]
0000018 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libpython3.6m.so.1.0(_PyEval_EvalFrameDefault+0x3002) [0x7fb30bb98902]
0000019 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libpython3.6m.so.1.0(+0x164cde) [0x7fb30bb94cde]
0000020 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libpython3.6m.so.1.0(PyEval_EvalCodeEx+0x6d) [0x7fb30bb9530d]
0000021 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libpython3.6m.so.1.0(PyEval_EvalCode+0x3b) [0x7fb30bb9535b]
0000022 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libpython3.6m.so.1.0(PyRun_StringFlags+0x92) [0x7fb30bbd0772]
0000023 0x7fb30c02e2d4 in Base::InterpreterSingleton::runString(char const*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADBase.so+0x54
0000024 0x7fb30cc70f2a in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADGui.so+0x12a
0000025 0x7fb30cc713c4 in Gui::Command::updateActive() from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADGui.so+0x24
0000026 0x7fb23dc7663e in CmdPartCompound::activated(int) from /tmp/.mount_FreeCA4MX3xs/usr/lib/PartGui.so+0x33e
0000027 0x7fb30cc7512c in Gui::Command::invoke(int) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADGui.so+0x4c
0000028 0x7fb307bed8d1 in QMetaObject::activate(QObject*, int, int, void**) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Core.so.5+0x2c1
0000029 0x7fb308568372 in QAction::triggered(bool) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5+0x32
0000030 0x7fb30856b09d in QAction::activate(QAction::ActionEvent) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5+0x5d
0000031 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5(+0x2d8112) [0x7fb3086ec112]
0000032 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5(+0x2dd280) [0x7fb3086f1280]
0000033 0x7fb3086f4dcb in QMenu::mouseReleaseEvent(QMouseEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5+0x24b
0000034 0x7fb3085b473a in QWidget::event(QEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5+0x96a
0000035 0x7fb3086f569b in QMenu::event(QEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5+0x8b
0000036 0x7fb308571c6c in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5+0x9c
0000037 0x7fb308576b5d in QApplication::notify(QObject*, QEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5+0xc6d
0000038 0x7fb30cc4c351 in Gui::GUIApplication::notify(QObject*, QEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADGui.so+0x41
#39 0x7fb307bc3425 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Core.so.5+0x75
#40 0x7fb308575860 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5+0x1a0
0000041 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5(+0x1ba274) [0x7fb3085ce274]
0000042 /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5(+0x1bc2c3) [0x7fb3085d02c3]
0000043 0x7fb308571c6c in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5+0x9c
0000044 0x7fb3085762ea in QApplication::notify(QObject*, QEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Widgets.so.5+0x3fa
0000045 0x7fb30cc4c351 in Gui::GUIApplication::notify(QObject*, QEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADGui.so+0x41
0000046 0x7fb307bc3425 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Core.so.5+0x75
0000047 0x7fb307f677db in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Gui.so.5+0x40b
0000048 0x7fb307f68f75 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Gui.so.5+0x115
0000049 0x7fb307f4a74b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Gui.so.5+0x7b
0000050 /tmp/.mount_FreeCA4MX3xs/usr/lib/libQt5XcbQpa.so.5(+0xa05d0) [0x7fb2ffdde5d0]
0000051 /tmp/.mount_FreeCA4MX3xs/usr/lib/libglib-2.0.so.0(+0x569be) [0x7fb3035519be]
0000052 /tmp/.mount_FreeCA4MX3xs/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x33) [0x7fb303552826]
0000053 /tmp/.mount_FreeCA4MX3xs/usr/lib/libglib-2.0.so.0(+0x57a0b) [0x7fb303552a0b]
0000054 /tmp/.mount_FreeCA4MX3xs/usr/lib/libglib-2.0.so.0(g_main_context_iteration+0x4a) [0x7fb303552acf]
0000055 0x7fb307c1498c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Core.so.5+0x5c
0000056 0x7fb307bc153b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Core.so.5+0xfb
0000057 0x7fb307bc9466 in QCoreApplication::exec() from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libQt5Core.so.5+0x86
0000058 0x7fb30cbe921c in Gui::Application::runApplication() from /tmp/.mount_FreeCA4MX3xs/usr/bin/../lib/libFreeCADGui.so+0x16bc
0000059 /tmp/.mount_FreeCA4MX3xs/usr/bin/FreeCAD(main+0x6c9) [0x403829]
0000060 /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7fb30682fb97]
0000061 /tmp/.mount_FreeCA4MX3xs/usr/bin/FreeCAD() [0x404699]
TagsPart

Activities

fonte

2019-06-07 12:30

reporter  

Crash.FCStd (71,578 bytes)

fonte

2019-06-07 12:33

reporter   ~0013156

OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16110 (Git) AppImage
Build type: Release
Branch: (HEAD detached at 0.18.1)
Hash: f7dccfaa909e5b9da26bf50c4a22ccca9bb10c40
Python version: 3.6.7
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Portuguese/Brazil (pt_BR)

openBrain

2019-06-07 16:37

developer   ~0013162

Not reproduced with both :
OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.1.
Build type: Release
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)

And
OS: Ubuntu 18.04.2 LTS (KDE/plasma)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.
Build type: Release
Python version: 3.6.7
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)

Everything's OK.
@fonte : could you open a forum thread as required in the giant yellow banner so it can be discussed ?

wmayer

2019-06-12 09:21

administrator   ~0013185

https://github.com/FreeCAD/FreeCAD/commit/b60a736c0de2a254069f9813bca88c3763cacfbd

Kunda1

2019-06-13 04:10

administrator   ~0013190

@wmayer just fyi, looks like yorik got the mantis source integration plugin to work again. So you may not need to add git commit urls anymore. :+1:

Related Changesets

FreeCAD: master b60a736c

2019-06-12 09:20:48

wmayer

Details Diff
fixes 0004010: Box Selection + Part -> MakeCompound will crash FreeCAD Affected Issues
0004010
mod - src/Mod/Part/App/FeatureCompound.cpp Diff File
mod - src/Mod/Part/Gui/Command.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderCompound.cpp Diff File

FreeCAD: releases/FreeCAD-0-18 b80d000a

2019-06-12 09:20:48

wmayer

Details Diff
fixes 0004010: Box Selection + Part -> MakeCompound will crash FreeCAD Affected Issues
0004010
mod - src/Mod/Part/App/FeatureCompound.cpp Diff File
mod - src/Mod/Part/Gui/Command.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderCompound.cpp Diff File

Issue History

Date Modified Username Field Change
2019-06-07 12:30 fonte New Issue
2019-06-07 12:30 fonte Tag Attached: Part
2019-06-07 12:30 fonte File Added: Crash.FCStd
2019-06-07 12:33 fonte Note Added: 0013156
2019-06-07 16:37 openBrain Note Added: 0013162
2019-06-11 16:24 wmayer Status new => confirmed
2019-06-12 09:21 wmayer Assigned To => wmayer
2019-06-12 09:21 wmayer Status confirmed => closed
2019-06-12 09:21 wmayer Resolution open => fixed
2019-06-12 09:21 wmayer Fixed in Version => 0.19
2019-06-12 09:21 wmayer Note Added: 0013185
2019-06-12 14:36 yorik Changeset attached => FreeCAD releases/FreeCAD-0-18 b80d000a
2019-06-12 14:36 yorik Changeset attached => FreeCAD master b60a736c
2019-06-13 04:10 Kunda1 Note Added: 0013190