View Issue Details

IDProjectCategoryView StatusLast Update
0004008Path[FreeCAD] Bugpublic2019-06-23 21:52
ReportersliptonicAssigned Toruss4262 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.19 
Target Version[FreeCAD] 0.19Fixed in Version[FreeCAD] 0.18 
Summary0004008: Phantom paths are displayed when job origin is moved.
Descriptionhttps://forum.freecadweb.org/viewtopic.php?f=15&t=36825&p=312726#p312726
TagsNo tags attached.

Activities

russ4262

2019-06-06 21:08

developer   ~0013153

The situation presented in the FreeCAD forum link in the Description above is fixed with two things:
  1. Toggle original part visibility to OFF and the Job's Model group to ON - before making any changes or additions to the new Job.
  2. Be sure to click the `Refresh` button in Job->Setup-Layout tab when moving the clone around with the translation tools - just prior to clicking OK to create/save the Job. This is because start/final depths are based off the Stock; so, if it is not refreshed, it does not align to the model's new location.


That is NOT to say that there is no bug. I noticed that using the if you select the head of the Job in the object tree and toggle its visibility, OR hide selection, that only the phantom paths disappear/re-appear.

I think the issue is related to transformation of either the Job, the Body, or related sub-component of these.

diamond-circ-sqr-2-nu.FCStd (46,825 bytes)
diamond-circ-sqr-2-phantom.FCStd (82,221 bytes)

russ4262

2019-06-20 05:09

developer   ~0013274

Thanks to @sliptonic for assistance in properly applying the fix.
Source of phantom paths is that in specific use cases, the Job was the active object for transformations performed in Job->Setup->Layout, rather than a Job base being the active object.

Follow-up to improve this fix is to add a selection gate limiting selection during Job model editing to bases or stock belonging to current Job being edited.

Current fix is included in FreeCAD Pull Request 2276

Related Changesets

FreeCAD: master 8b3c4ac0

2019-06-20 04:35:13

russ4262

Details Diff
Fixes bug 0004008: removes phantom path cause

Job object was base of transformations, rather than Job base(clone).
Affected Issues
0004008
mod - src/Mod/Path/PathScripts/PathJobGui.py Diff File

FreeCAD: master 332bfb50

2019-06-20 04:35:13

russ4262

Details Diff
Fixes bug 0004008: removes phantom path cause

Job object was base of transformations, rather than Job base(clone).
Affected Issues
0004008
mod - src/Mod/Path/PathScripts/PathJobGui.py Diff File

FreeCAD: releases/FreeCAD-0-18 43510585

2019-06-20 04:35:13

russ4262


Committer: wmayer Details Diff
Fixes bug 0004008: removes phantom path cause

Job object was base of transformations, rather than Job base(clone).
Affected Issues
0004008
mod - src/Mod/Path/PathScripts/PathJobGui.py Diff File

Issue History

Date Modified Username Field Change
2019-06-06 15:47 sliptonic New Issue
2019-06-06 21:08 russ4262 File Added: diamond-circ-sqr-2-nu.FCStd
2019-06-06 21:08 russ4262 File Added: diamond-circ-sqr-2-phantom.FCStd
2019-06-06 21:08 russ4262 Note Added: 0013153
2019-06-17 08:09 Kunda1 Status new => confirmed
2019-06-20 04:27 russ4262 Assigned To => russ4262
2019-06-20 04:27 russ4262 Status confirmed => assigned
2019-06-20 05:09 russ4262 Note Added: 0013274
2019-06-20 12:59 russ4262 Changeset attached => FreeCAD master 8b3c4ac0
2019-06-20 12:59 russ4262 Changeset attached => FreeCAD master 332bfb50
2019-06-22 12:39 wmayer Changeset attached => FreeCAD releases/FreeCAD-0-18 43510585
2019-06-23 21:52 wmayer Status assigned => closed
2019-06-23 21:52 wmayer Resolution open => fixed
2019-06-23 21:52 wmayer Fixed in Version => 0.18