View Issue Details

IDProjectCategoryView StatusLast Update
0004006FEM[FreeCAD] Bugpublic2019-06-11 08:04
ReportermhabakukAssigned Toberndhahnebach 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionopen 
Product Version[FreeCAD] 0.18 
Target VersionFixed in Version 
Summary0004006: Fehlermeldung ELMER
DescriptionElmer endet mit folgender Fehlermeldung nach korrekter Rechnung, kann danach keine Ergebnisse anzeigen:

Exception in thread Thread-18:
Traceback (most recent call last):
  File "C:\Program Files\FreeCAD 0.18\bin\lib\threading.py", line 916, in _bootstrap_inner
    self.run()
  File "C:\Program Files\FreeCAD 0.18\bin\lib\threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "C:\Program Files\FreeCAD 0.18\Mod\Fem\femsolver\task.py", line 115, in protector
    self.run()
  File "C:\Program Files\FreeCAD 0.18\Mod\Fem\femsolver\elmer\tasks.py", line 107, in run
    self._updateOutput(output)
  File "C:\Program Files\FreeCAD 0.18\Mod\Fem\femsolver\elmer\tasks.py", line 115, in _updateOutput
    self.solver.ElmerOutput.Text = output.decode("utf-8")
AttributeError: 'str' object has no attribute 'decode'

aber nur unter 0.18, nicht unter 0.17
Steps To ReproduceFEM mit Elmer berechnen >> ergibt das Fehlerlog
TagsNo tags attached.

Activities

Kunda1

2019-06-06 14:27

administrator   ~0013150

Please read our bugtracker guidelines before posting tickets. Especially FEM tickets because it is heavily developed and to stay current you need to use the latest 0.19_pre version to benefit from bugfixes and changes.
Please open a thread on the FEM subforum https://forum.freecadweb.org/viewforum.php?f=18 (please do so in english, if not then post to the german subforum as I mentioned in 0004007)

punting to @berndhahnebach nevertheless

berndhahnebach

2019-06-07 14:49

developer   ~0013157

would you make a new topic on the forum ...

there it would be best to post a simple file and your FreeCAD version informations.

I would assume some Python2 vs Python3 problem ...

Kunda1

2019-06-07 15:10

administrator   ~0013158

@berndhahnebach shall we close this ticket ?

mhabakuk

2019-06-07 16:25

reporter   ~0013160

hee data and example as required

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16110 (Git)
Build type: Release
Branch: (HEAD detached at upstream/releases/FreeCAD-0-18)
Hash: f7dccfaa909e5b9da26bf50c4a22ccca9bb10c40
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)

consider that the example works well under 0.17 on same system

FEM 0004006 Fehlermeldung ELMER.FCStd (26,298 bytes)

berndhahnebach

2019-06-11 07:44

developer   ~0013178

Kunda1 wrote

@berndhahnebach shall we close this ticket ?
No

berndhahnebach

2019-06-11 07:50

developer   ~0013179

confirmed for:

OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.16878 (Git)
Build type: Release
Branch: master
Hash: 50f91840d677ba77d3a938d9ac0aa73f6a9f12d4
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Switzerland (de_CH)

berndhahnebach

2019-06-11 07:59

developer   ~0013180

https://github.com/FreeCAD/FreeCAD/commit/5e454da2e24fa143d7688a1199a841f88c5f1144

berndhahnebach

2019-06-11 08:03

developer   ~0013181

https://forum.freecadweb.org/viewtopic.php?f=10&t=36972

Issue History

Date Modified Username Field Change
2019-06-06 11:46 mhabakuk New Issue
2019-06-06 14:27 Kunda1 Note Added: 0013150
2019-06-06 14:27 Kunda1 Assigned To => berndhahnebach
2019-06-06 14:27 Kunda1 Status new => assigned
2019-06-06 14:27 Kunda1 Project FreeCAD => FEM
2019-06-07 14:49 berndhahnebach Note Added: 0013157
2019-06-07 15:10 Kunda1 Note Added: 0013158
2019-06-07 16:25 mhabakuk File Added: FEM 0004006 Fehlermeldung ELMER.FCStd
2019-06-07 16:25 mhabakuk Note Added: 0013160
2019-06-11 07:44 berndhahnebach Note Added: 0013178
2019-06-11 07:50 berndhahnebach Note Added: 0013179
2019-06-11 07:59 berndhahnebach Note Added: 0013180
2019-06-11 08:03 berndhahnebach Note Added: 0013181
2019-06-11 08:04 berndhahnebach Status assigned => closed