View Issue Details

IDProjectCategoryView StatusLast Update
0003969FreeCADBugpublic2019-06-13 07:01
Reporterchrisb Assigned Tochrisb  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.19 
Target Version0.19Fixed in Version0.19 
Summary0003969: OSX: Spaces in path to FreeCAD program not supported
DescriptionFreeCAD doesn't start if the path to the FreeCAD program folder contains a space.

Forum discussion
TagsMacOSX
FreeCAD Information

Activities

chrisb

2019-05-12 22:39

developer   ~0013101

This worked before because the binary FreeCAD was placed directly in the folder
FreeCAD.app/Contents/MacOS/. Now it is a shell script.

Solution working here:

Change the last line in FreeCAD.app/Contents/MacOS/FreeCAD from
$PREFIX/bin/FreeCAD $@
to
"$PREFIX/bin/FreeCAD" $@

Kunda1

2019-05-13 16:42

administrator   ~0013107

@chrisb do you plan to submit a PR? :)

looo

2019-06-13 06:29

developer   ~0013197

Can we close this one. The suggestion was already applied.

Issue History

Date Modified Username Field Change
2019-05-12 22:21 chrisb New Issue
2019-05-12 22:39 chrisb Note Added: 0013101
2019-05-13 16:42 Kunda1 Note Added: 0013107
2019-05-13 16:42 Kunda1 Status new => feedback
2019-05-14 17:06 Kunda1 Tag Attached: MacOSX
2019-05-14 17:06 Kunda1 Target Version => 0.19
2019-06-13 06:29 looo Note Added: 0013197
2019-06-13 07:01 chrisb Assigned To => chrisb
2019-06-13 07:01 chrisb Status feedback => closed
2019-06-13 07:01 chrisb Resolution open => fixed
2019-06-13 07:01 chrisb Fixed in Version => 0.19