View Issue Details

IDProjectCategoryView StatusLast Update
0003950Part[All Projects] Generalpublic2019-09-03 23:46
Reporterfenrir482 Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSLinuxOS VersionLinux Mint 19.1
Product Version[FreeCAD] 0.18 
Target VersionFixed in Version[FreeCAD] 0.19 
Summary0003950: when you change sphere settings in part it doesn't refresh when pressing enter
Descriptionwhen you change sphere settings in part it doesn't refresh when pressing enter
Steps To Reproduce1. Just open a new part
2. create a new sphere
3. edit any of its angles
4. press enter
Additional InformationOS: Linux Mint 19.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.1.
Build type: Release
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Spanish/Spain (es_ES)
Tagslinux, Part
FreeCAD Information

Relationships

related to 0003936 closed FreeCAD When property (combo view) data is modified the enter key does not work correctly. 

Activities

fenrir482

2019-04-29 20:27

reporter  

2019-04-29_22-06-35.mkv (2,274,149 bytes)

Kunda1

2019-04-30 01:20

administrator   ~0013071

Can you recreate this on 0.18 appimage? and on 0.19_pre ?
https://github.com/FreeCAD/FreeCAD/releases/tag/0.19_pre

fenrir482

2019-04-30 16:14

reporter   ~0013073

Hello Kunda1, the 0.18 appimage is not available to download in this moment, the link takes me to a page in github with (error 404 page not found, and I couldn't try this version.
I have downloaded FreeCAD_0.19-16540-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage from https://github.com/FreeCAD/FreeCAD/releases/tag/0.19_pre, and I have tried it, with the same results.
Thank you so much for your answer.

openBrain

2019-08-31 11:36

developer   ~0013496

Last edited: 2019-08-31 11:36

View 2 revisions

Can't reproduce this bug anymore with 0.19 version of 2019/08/21. Everything works as expected.
Is this ticket still useful ?

openBrain

2019-09-03 15:27

developer   ~0013524

@fenrir482 : could you please test again with latest 0.19 and confirm it's fixed ?

fenrir482

2019-09-03 20:23

reporter   ~0013529

Hello openbrain, I have tried FreeCAD_0.19-18009-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage an as you said an it works perfectly.
Thanks for your attention, and congratulations for this great software, you are doing an excellent work with this software.

Kunda1

2019-09-03 23:46

administrator   ~0013531

Thanks fenrir482 and openBrain
Closing ticket

BTW, @fenrir482 please follow our bugtracker guidelines next time. Thank you for your consideration

Issue History

Date Modified Username Field Change
2019-04-29 20:27 fenrir482 New Issue
2019-04-29 20:27 fenrir482 Tag Attached: linux
2019-04-29 20:27 fenrir482 Tag Attached: Part
2019-04-29 20:27 fenrir482 File Added: 2019-04-29_22-06-35.mkv
2019-04-30 01:20 Kunda1 Note Added: 0013071
2019-04-30 01:20 Kunda1 Status new => feedback
2019-04-30 16:14 fenrir482 Note Added: 0013073
2019-04-30 16:14 fenrir482 Status feedback => new
2019-08-31 11:36 openBrain Note Added: 0013496
2019-08-31 11:36 openBrain Note Edited: 0013496 View Revisions
2019-08-31 11:40 openBrain Relationship added related to 0003936
2019-09-03 15:27 openBrain Note Added: 0013524
2019-09-03 20:23 fenrir482 Note Added: 0013529
2019-09-03 23:46 Kunda1 Status new => closed
2019-09-03 23:46 Kunda1 Resolution open => fixed
2019-09-03 23:46 Kunda1 Fixed in Version => 0.19
2019-09-03 23:46 Kunda1 Note Added: 0013531