View Issue Details

IDProjectCategoryView StatusLast Update
0003936FreeCAD[All Projects] Generalpublic2019-09-05 19:42
Reporterfreedman Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target VersionFixed in Version0.19 
Summary0003936: When property (combo view) data is modified the enter key does not work correctly.
DescriptionNormal computer usage is to use the "Enter key" to confirm some kind of data change. When changing property data the Enter key doesn't follow the correct procedure to bring the data into the program and process the data i.e. recompute.

https://forum.freecadweb.org/viewtopic.php?f=3&t=34875
Steps To ReproduceIn the property fields when a data value is modified, the only way to trigger a recompute is to mouse click in a field above or below, using the Enter key does not trigger a recompute. Using the Enter key is almost worse because the "property change data flag" is reset I presume, this makes it so clicking above or below (the edited field) doesn't work. The only way to recompute at that point is to modify data without using the Enter key.
Additional InformationOS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16093 +17 (Git)
Build type: Release
Branch: (HEAD detached at 0.18.1)
Hash: f7dccfaa909e5b9da26bf50c4a22ccca9bb10c40
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0003950 closed Part when you change sphere settings in part it doesn't refresh when pressing enter 

Activities

freedman

2019-04-17 16:35

reporter   ~0013029

To reproduce, make a cube and change the height. Then use the enter key.

openBrain

2019-08-31 11:39

developer   ~0013497

Can't reproduce this bug anymore with 0.19 version of 2019/08/21. Everything works as expected. The view is even updated in real-time when entering value.
Is this ticket still useful ?

openBrain

2019-09-03 15:27

developer   ~0013523

@freedman : could you test with latest 0.19 and confirm it's fixed ?

freedman

2019-09-04 18:14

reporter   ~0013532

I have tested the current version of 0.19.17421 and the problem does looked fixed. Good work, thank you.

Kunda1

2019-09-05 19:42

administrator   ~0013534

Great. Thanks to all for the effort here.
Marking fixed in 0.19 and closing

Issue History

Date Modified Username Field Change
2019-04-17 16:18 freedman New Issue
2019-04-17 16:35 freedman Note Added: 0013029
2019-04-22 14:42 Kunda1 Summary When property ( combo view) data is modified the enter key does not work correctly. => When property (combo view) data is modified the enter key does not work correctly.
2019-08-31 11:39 openBrain Note Added: 0013497
2019-08-31 11:40 openBrain Relationship added related to 0003950
2019-09-03 15:27 openBrain Note Added: 0013523
2019-09-04 18:14 freedman Note Added: 0013532
2019-09-05 19:42 Kunda1 Status new => closed
2019-09-05 19:42 Kunda1 Resolution open => fixed
2019-09-05 19:42 Kunda1 Fixed in Version => 0.19
2019-09-05 19:42 Kunda1 Note Added: 0013534