View Issue Details

IDProjectCategoryView StatusLast Update
0003934FreeCADBugpublic2019-06-13 22:42
ReporterMD101Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformWindows 7 pro 64OSOS Version
Product Version0.17 
Target VersionFixed in Version 
Summary0003934: Crash when selecting XZ, XY, YZ in part design
DescriptionI am brand new to this program and following the online tutorial to get up to speed. I have no problem creating the new part and naming it but when I create a new sketch and select any of the plane the moment I click "OK" the FreeCad stops working and I have to close the program. I would really like to get this program working as I think it will be invaluable for things I want to make.
Steps To Reproduce1. Open Part Design
2. Create New Part
3. Create Sketch
4. Select a plane
5. Click OK

Basically follow the online tutorial for absolute beginners and you'll reproduce the issue. Also FYI, I just did a Windows update this morning before I installed the program so I know my computer operating system is up to date.
Additional InformationOS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git)
Build type: Release
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)
Tagscrash, Part Design, Sketch

Activities

Kunda1

2019-04-24 11:17

administrator   ~0013040

@MD101 please try with v0.18.1 and report back
https://github.com/FreeCAD/FreeCAD/releases/tag/0.18.1

Kunda1

2019-06-13 04:52

administrator   ~0013196

@MD101 please follow up

MD101

2019-06-13 16:22

reporter   ~0013202

Hi Kunda1,
Sorry for the delay.
I installed the version you mentioned at github and it fixed my problem.
I've noticed what seems to be a few other quirks but nothing I haven't been able to work around. I'm enjoying using Freecad and looking forward to creating some good things.
Thanks again for your help.

Kunda1

2019-06-13 22:42

administrator   ~0013206

@MD101 please also consider using the 0.19dev version (it can co-exist with 0.18) to see if said quirks are still there. If so, please post a forum thread about them. FreeCAD is actively hacked on, daily. We're working on making the UX as good as we want it to be. Cheers.

Closing ticket.

Issue History

Date Modified Username Field Change
2019-04-13 13:48 MD101 New Issue
2019-04-13 13:48 MD101 Tag Attached: crash
2019-04-13 13:48 MD101 Tag Attached: Part Design
2019-04-13 13:48 MD101 Tag Attached: Sketch
2019-04-24 11:17 Kunda1 Status new => feedback
2019-04-24 11:17 Kunda1 Note Added: 0013040
2019-06-13 04:52 Kunda1 Note Added: 0013196
2019-06-13 16:22 MD101 Note Added: 0013202
2019-06-13 16:22 MD101 Status feedback => new
2019-06-13 22:42 Kunda1 Status new => closed
2019-06-13 22:42 Kunda1 Resolution open => no change required
2019-06-13 22:42 Kunda1 Note Added: 0013206