View Issue Details

IDProjectCategoryView StatusLast Update
0003926SketcherBugpublic2019-06-28 08:49
Reporterkisolre Assigned Toabdullah  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.19 
Target Version0.19Fixed in Version 
Summary0003926: Carbon copy in construction mode reports wrong constraint redundancy.
DescriptionIn the attached file when trying to carbon copy that sketch(fully constrained, no redundancies) to a new empty sketch in construction mode two constraints are reported as redundant.
.
Steps To ReproduceOpen the file.
Create new sketch, XY plane.
Toggle construction mode On.
Make sure Auto Remove Redundants is Off
Carbon Copy Sketch005 - constraints 21,24 are showed as redundant.
Undo
Toggle construction mode Off.
Carbon Copy Sketch005 - no redundant constraints.
Additional InformationForum thread
Versions tested:
OS: Windows 8.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.16267 (Git)
Build type: Release
Branch: master
Hash: ddb335cfe057336f1958d68126bb0471328d735c
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Bulgarian/Bulgaria (bg_BG)
OS: Windows 8.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15816 (Git)
Build type: Release
Branch: master
Hash: 7ee0e4d43909ec688299b8498b240cccf8362c47
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Bulgarian/Bulgaria (bg_BG)
OS: Windows 8.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git)
Build type: Release
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: Bulgarian/Bulgaria (bg_BG)
0.17 shows only 24 as redundant
TagsNo tags attached.
FreeCAD Information

Activities

kisolre

2019-04-05 16:58

reporter  

CarbonCopyConstructionMode.FCStd (3,888 bytes)

abdullah

2019-06-22 21:15

manager   ~0013300

Fix committed to master branch.

abdullah

2019-06-28 08:49

manager   ~0013315

Fix committed to releases/FreeCAD-0-18 branch.

Related Changesets

FreeCAD: master e632e9fe

2019-06-22 21:12:19

abdullah


Committer: abdullahtahiriyo Details Diff
Sketcher: Fix carbon copy construction points

=============================================

fixes 0003926

Points made of construction type are special non-constrainable points, such as (current) bspline knots.

This was not intended in Carbon Copy.
Affected Issues
0003926
mod - src/Mod/Sketcher/App/SketchObject.cpp Diff File

FreeCAD: releases/FreeCAD-0-18 2f0c3a79

2019-06-22 21:12:19

abdullah


Committer: wmayer Details Diff
Sketcher: Fix carbon copy construction points

=============================================

fixes 0003926

Points made of construction type are special non-constrainable points, such as (current) bspline knots.

This was not intended in Carbon Copy.
Affected Issues
0003926
mod - src/Mod/Sketcher/App/SketchObject.cpp Diff File

Issue History

Date Modified Username Field Change
2019-04-05 16:58 kisolre New Issue
2019-04-05 16:58 kisolre File Added: CarbonCopyConstructionMode.FCStd
2019-04-05 22:05 Kunda1 Status new => confirmed
2019-04-05 22:05 Kunda1 Target Version => 0.19
2019-04-05 22:05 Kunda1 Description Updated View Revisions
2019-04-05 22:05 Kunda1 Steps to Reproduce Updated View Revisions
2019-04-05 22:05 Kunda1 Additional Information Updated View Revisions
2019-06-22 21:15 abdullah Changeset attached => FreeCAD master e632e9fe
2019-06-22 21:15 abdullah Note Added: 0013300
2019-06-22 21:15 abdullah Assigned To => abdullah
2019-06-22 21:15 abdullah Status confirmed => closed
2019-06-22 21:15 abdullah Resolution open => fixed
2019-06-28 08:49 wmayer Changeset attached => FreeCAD releases/FreeCAD-0-18 2f0c3a79
2019-06-28 08:49 abdullah Note Added: 0013315