View Issue Details

IDProjectCategoryView StatusLast Update
0003892FEM[FreeCAD] Bugpublic2019-03-23 12:31
Reporterlidgaca Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformLinux X64OSMate (Ubuntu)OS Version18 (Ub Xenial)
Product Version[FreeCAD] 0.18 
Target VersionFixed in Version 
Summary0003892: Clicking on the 'Use FreeCAD material editor' button on the Model -> Material -> Material for Solid task panel crashes FreeCAD
DescriptionRef: [url=https://forum.freecadweb.org/viewtopic.php?f=18&t=34712 ]forum discusison[/url]

I'm using I'm using the 16027 appimage, and whenever I try to click on the material editor button on the Material for Solid task panel the application crashes with stack trace (below).

100% reproducible on my machine.
Steps To ReproduceCreate simple model (cube or sphere will do)
Open FEM WB
Create a new Analysis
Single click on the model in the combo view to select it
Open Model -> Material -> Material for Solid task panel
Click on 'Use FreeCAD material editor

Bang

Stacktrace below
Additional InformationOS: Linux Mint 18
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16027 (Git) AppImage
Build type: Release
Branch: master
Hash: ad28ba509579d11ac1c6966dedaa70eb6476182b
Python version: 3.6.7
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedKingdom (en_GB)

Terminal output:

card_path:
Previously used material card cannot be found in material directories. Add document material.
For some reason all material data is empty!
Density not found in material data of: Empty
YoungsModulus not found in material data of: Empty
PoissonRatio not found in material data of: Empty
ThermalConductivity not found in material data of: Empty
ThermalExpansionCoefficient not found in material data of: Empty
SpecificHeat not found in material data of: Empty
False
locations to look for material cards:
  /tmp/.mount_freeca7QjeSH/usr/data/Mod/Material/StandardMaterial
  /home/lidgaca/.FreeCAD/Material


Program received signal SIGSEGV, Segmentation fault.
#0 /lib/x86_64-linux-gnu/libc.so.6(+0x354b0) [0x7f4842b734b0]
#1 /tmp/.mount_freeca7QjeSH/usr/lib/python3.6/lib-dynload/pyexpat.cpython-36m-x86_64-linux-gnu.so(XML_SetHashSalt+0x1b) [0x7f47e9b71bab]
0000002 /tmp/.mount_freeca7QjeSH/usr/lib/python3.6/lib-dynload/_elementtree.cpython-36m-x86_64-linux-gnu.so(+0x7faf) [0x7f47e9d99faf]
0000003 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0xe3b63) [0x7f4847e83b63]
0000004 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyObject_FastCallDict+0x8b) [0x7f4847e12a0b]
0000005 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164e48) [0x7f4847f04e48]
0000006 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyEval_EvalFrameDefault+0x3002) [0x7f4847f08902]
0000007 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164cde) [0x7f4847f04cde]
0000008 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164ff2) [0x7f4847f04ff2]
0000009 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyEval_EvalFrameDefault+0x3002) [0x7f4847f08902]
0000010 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164cde) [0x7f4847f04cde]
0000011 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164ff2) [0x7f4847f04ff2]
0000012 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyEval_EvalFrameDefault+0x3002) [0x7f4847f08902]
0000013 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164cde) [0x7f4847f04cde]
0000014 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164ff2) [0x7f4847f04ff2]
0000015 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyEval_EvalFrameDefault+0x3002) [0x7f4847f08902]
0000016 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164370) [0x7f4847f04370]
0000017 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x165294) [0x7f4847f05294]
0000018 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyEval_EvalFrameDefault+0x3002) [0x7f4847f08902]
0000019 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164cde) [0x7f4847f04cde]
0000020 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyFunction_FastCallDict+0x165) [0x7f4847f0e035]
0000021 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyObject_FastCallDict+0x17e) [0x7f4847e12afe]
0000022 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyObject_Call_Prepend+0xce) [0x7f4847e12bee]
0000023 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(PyObject_Call+0x6a) [0x7f4847e128aa]
0000024 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0xeb2f9) [0x7f4847e8b2f9]
0000025 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0xe3b63) [0x7f4847e83b63]
0000026 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyObject_FastCallDict+0x8b) [0x7f4847e12a0b]
0000027 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyObject_FastCallKeywords+0x6e) [0x7f4847e12e6e]
0000028 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164e48) [0x7f4847f04e48]
0000029 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyEval_EvalFrameDefault+0x1246) [0x7f4847f06b46]
0000030 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164370) [0x7f4847f04370]
0000031 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x165294) [0x7f4847f05294]
0000032 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyEval_EvalFrameDefault+0x3002) [0x7f4847f08902]
0000033 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(+0x164370) [0x7f4847f04370]
0000034 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyFunction_FastCallDict+0x2c6) [0x7f4847f0e196]
0000035 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyObject_FastCallDict+0x17e) [0x7f4847e12afe]
0000036 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(_PyObject_Call_Prepend+0xce) [0x7f4847e12bee]
0000037 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpython3.6m.so.1.0(PyObject_Call+0x6a) [0x7f4847e128aa]
0000038 0x7f48437bbf0f in PySide::SignalManager::callPythonMetaMethod(QMetaMethod const&, void**, _object*, bool) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpyside2.cpython-36m-x86_64-linux-gnu.so.5.6+0x6f
#39 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libpyside2.cpython-36m-x86_64-linux-gnu.so.5.6(+0x1d10c) [0x7f48437c210c]
#40 0x7f4843ea9e59 in QMetaObject::activate(QObject*, int, int, void**) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Core.so.5+0x849
0000041 0x7f4844928282 in QAbstractButton::clicked(bool) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5+0x32
0000042 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5(+0x25847a) [0x7f484492847a]
0000043 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5(+0x2594ec) [0x7f48449294ec]
0000044 0x7f4844929664 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5+0xd4
0000045 0x7f484487073a in QWidget::event(QEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5+0x96a
0000046 0x7f484482dc6c in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5+0x9c
0000047 0x7f4844832b5d in QApplication::notify(QObject*, QEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5+0xc6d
0000048 0x7f4848fbc191 in Gui::GUIApplication::notify(QObject*, QEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libFreeCADGui.so+0x41
0000049 0x7f4843e7f425 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Core.so.5+0x75
0000050 0x7f4844831860 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5+0x1a0
0000051 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5(+0x1b9cd1) [0x7f4844889cd1]
0000052 /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5(+0x1bc2c3) [0x7f484488c2c3]
0000053 0x7f484482dc6c in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5+0x9c
0000054 0x7f48448322ea in QApplication::notify(QObject*, QEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Widgets.so.5+0x3fa
0000055 0x7f4848fbc191 in Gui::GUIApplication::notify(QObject*, QEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libFreeCADGui.so+0x41
0000056 0x7f4843e7f425 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Core.so.5+0x75
0000057 0x7f48442237db in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Gui.so.5+0x40b
0000058 0x7f4844224f75 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Gui.so.5+0x115
0000059 0x7f484420674b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Gui.so.5+0x7b
0000060 /tmp/.mount_freeca7QjeSH/usr/lib/libQt5XcbQpa.so.5(+0xa05d0) [0x7f483a75e5d0]
0000061 /tmp/.mount_freeca7QjeSH/usr/lib/libglib-2.0.so.0(+0x569be) [0x7f483d75c9be]
0000062 /tmp/.mount_freeca7QjeSH/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x33) [0x7f483d75d826]
0000063 /tmp/.mount_freeca7QjeSH/usr/lib/libglib-2.0.so.0(+0x57a0b) [0x7f483d75da0b]
0000064 /tmp/.mount_freeca7QjeSH/usr/lib/libglib-2.0.so.0(g_main_context_iteration+0x4a) [0x7f483d75dacf]
0000065 0x7f4843ed098c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Core.so.5+0x5c
0000066 0x7f4843e7d53b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Core.so.5+0xfb
0000067 0x7f4843e85466 in QCoreApplication::exec() from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libQt5Core.so.5+0x86
0000068 0x7f4848f5935b in Gui::Application::runApplication() from /tmp/.mount_freeca7QjeSH/usr/bin/../lib/libFreeCADGui.so+0x153b
0000069 /tmp/.mount_freeca7QjeSH/usr/bin/FreeCAD(main+0x6c9) [0x403829]
0000070 /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7f4842b5e830]
0000071 /tmp/.mount_freeca7QjeSH/usr/bin/FreeCAD() [0x404699]


The material editor button does work on the 16000 (py2 based) appimage. My guess would be this may be related to py3 issues.
TagsCoin3d, expat, upstream
FreeCAD Information

Activities

wmayer

2019-03-08 14:34

administrator   ~0012865

It's not directly a FreeCAD bug. The issue is caused by Coin3d which uses its private expat library version that is not binary compatible to the system version.

On Debian this must be already fixed:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=560928
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=884947
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=874727

Kunda1

2019-03-08 19:49

administrator   ~0012867

Resolving issue

Issue History

Date Modified Username Field Change
2019-03-08 10:09 lidgaca New Issue
2019-03-08 13:32 Kunda1 Description Updated View Revisions
2019-03-08 13:33 Kunda1 Assigned To => berndhahnebach
2019-03-08 13:33 Kunda1 Status new => assigned
2019-03-08 14:34 wmayer Note Added: 0012865
2019-03-08 19:48 Kunda1 Tag Attached: upstream
2019-03-08 19:48 Kunda1 Tag Attached: Coin3d
2019-03-08 19:49 Kunda1 Assigned To berndhahnebach =>
2019-03-08 19:49 Kunda1 Status assigned => resolved
2019-03-08 19:49 Kunda1 Resolution open => no change required
2019-03-08 19:49 Kunda1 Note Added: 0012867
2019-03-23 12:31 Kunda1 Tag Attached: expat
2019-03-23 12:31 Kunda1 Status resolved => closed