View Issue Details

IDProjectCategoryView StatusLast Update
0003890Part[FreeCAD] Bugpublic2019-07-16 11:42
ReporteruwestoehrAssigned To 
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.18 
Target Version[FreeCAD] 0.19Fixed in Version[FreeCAD] 0.19 
Summary0003890: missing tooltips in the Part preferences
DescriptionThis bug collects missing and unclear tooltips in the Part preferences.
Missing or incomplete tooltips will be denoted in the Wiki page:
https://www.freecadweb.org/wiki/Preferences_Editor
as '??' until information is available. If so, I will post them to this bug report to be implemented in form of tooltips.

In the IGES preferences:

The following tooltips are missing:
- Units for export of IGES
- Groups of Trimmed Surfaces (type 144) -> I added some info here that can be used for a tooltip: https://www.freecadweb.org/wiki/Preferences_Editor#IGES
- Solids (type 186) and Shells (type 514) / B-REP mode -> I added some info here that can be used for a tooltip: https://www.freecadweb.org/wiki/Preferences_Editor#IGES
- Skip blank entities
- Header (maybe not necessary because is self-explanatory)

In the STEP preferences:

The following tooltips are missing:
- Units for export of STEP (maybe tell the user why this setting is important, maybe not necessary)
- Header (maybe not necessary because is self-explanatory)
Tags#lowhangingfruit, tooltips

Activities

uwestoehr

2019-07-15 23:32

developer   ~0013348

This PR will fix the issue: https://github.com/FreeCAD/FreeCAD/pull/2345

Related Changesets

FreeCAD: master 4b4e48d5

2019-07-15 23:29:39

donovaly


Committer: wmayer Details Diff
add missing tooltips for part import/export Affected Issues
0003890
mod - src/Mod/Part/Gui/DlgImportExportIges.ui Diff File
mod - src/Mod/Part/Gui/DlgImportExportStep.ui Diff File

Issue History

Date Modified Username Field Change
2019-03-06 22:09 uwestoehr New Issue
2019-03-06 22:09 uwestoehr Tag Attached: tooltips
2019-03-31 16:14 Kunda1 Tag Attached: #lowhangingfruit
2019-03-31 16:14 Kunda1 Status new => confirmed
2019-03-31 16:14 Kunda1 Target Version => 0.19
2019-07-15 23:32 uwestoehr Note Added: 0013348
2019-07-16 11:41 wmayer Changeset attached => FreeCAD master 4b4e48d5
2019-07-16 11:42 wmayer Status confirmed => closed
2019-07-16 11:42 wmayer Resolution open => fixed
2019-07-16 11:42 wmayer Fixed in Version => 0.19