View Issue Details

IDProjectCategoryView StatusLast Update
0003876FreeCADBugpublic2019-07-29 14:57
Reporteruwestoehr Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target VersionFixed in Version0.18 
Summary0003876: Spreadsheet WB does not respect number of decimal settings
DescriptionIn the preferences I can set the number of decimals and this setting is respected by almost all parts of FreeCAD. The spreadsheet WB however, doesn't respect this. To reproduce:

- set e.g. the decimals to '3'
- in a table cell input "1.1111111111" (e.g. you performed a calculation in an external program and just paste a division by 9 result)

result: you get "1.11111"

So always 5 decimals are used, not matter what you set in the preferences.

This is a disadvantage because users might e.g. write values to tables as meters and want to have micrometer precision later in the construction and thus need 6 decimals. Or one has a milling machine with a precision not better then 10 micron and you like to specify values as millimeters. Then you don't like to see 5 decimals but only 2.
Additional Informationforum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=34564

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15991 (Git)
Build type: Release
Branch: master
Hash: 10c745175f8a121b594ee6b0612cc487ebf43ba1
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)
TagsNo tags attached.
FreeCAD Information

Related Changesets

FreeCAD: releases/FreeCAD-0-18 58aa9b18

2019-03-02 22:07:49

wmayer

Details Diff
fixes 0003876: Spreadsheet WB does not respect number of decimal settings
fixes 0003875: Spreadsheet workbench does not respect locale for decimal separator
Affected Issues
0003875, 0003876
mod - src/Mod/Spreadsheet/Gui/SheetModel.cpp Diff File

Issue History

Date Modified Username Field Change
2019-03-01 23:46 uwestoehr New Issue
2019-03-02 22:08 wmayer Status new => closed
2019-03-02 22:08 wmayer Resolution open => fixed
2019-03-02 22:08 wmayer Fixed in Version => 0.18
2019-03-02 22:08 wmayer Note Added: 0012822
2019-07-29 14:57 Kunda1 Changeset attached => FreeCAD releases/FreeCAD-0-18 58aa9b18