View Issue Details

IDProjectCategoryView StatusLast Update
0003866FreeCADFeaturepublic2019-07-16 12:00
Reporteruwestoehr Assigned Touwestoehr  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target Version0.19Fixed in Version 
Summary0003866: Missing tooltips in preferences dialog
DescriptionThis is a meta issue to collect missing tooltips in FC's preferences dialog.

Section General: there are no tooltips at all, there should be at least tooltips for:
- enable tiled background
- save thumbnail into project file
- Allow duplicate object labels...
- Redirect internal Python... (both options)
- Run Macros in Local environment
- Recording GUI commands
- Record as comment

Section Display: there is only one single tooltip, there should be at least tooltips for:
- Show counter of frames...
- Use OpenGL vertex ...
- Enable animation
- radio buttons for camera type
- Middle Color
- Two-side rendering

Section Import-Export: There are some tooltips missing:
- Create clones
- all options in the tab IGES
There are missing line breaks in tooltips:
- all tooltips in IFC export options

Section Start: there is only one tooltip missing:
- Use gradient for new file icon
- show bounding-box...
Additional InformationTooltips help average users a lot since one could then often save to google around what a certain setting actually means.
Tags#lowhangingfruit, tooltips
FreeCAD Information

Activities

uwestoehr

2019-03-03 19:16

developer   ~0012833

Last edited: 2019-03-09 19:58

View 3 revisions

- The option
"User system"
in the units tab should be renamed to
"Unit system"
because this is what it really is.

- The macro option
"Recording GUI commands"
should be renamed to
"Record GUI commands"
to avoid confusions.

- The 3D view option
"Drag at cursor"
should be renamed to
"Rotate at cursor""
because this is what is actually the case (info from wmayer)

Kunda1

2019-03-07 14:01

administrator   ~0012857

Last edited: 2019-03-07 14:01

View 3 revisions

'Unit System' and 'Record GUI commands' fix
FreeCAD Pull Request 2008

uwestoehr

2019-03-07 23:31

developer   ~0012859

To avoid misunderstandings: I just collect for now since the strings are already frozen for FC 0.18. I will also make some PRs as soon as master is open for FC 0.19 development.

wmayer

2019-03-22 16:32

administrator   ~0012944

https://github.com/FreeCAD/FreeCAD/commit/dfb2389ca69b643ee006c0a1f73c14db969f7d73

Kunda1

2019-03-31 16:13

administrator   ~0012979

@uwestoehr lets systematicaly tackle this ticket. What is left to do here?

uwestoehr

2019-04-01 23:13

developer   ~0012984

> What is left to do here?

A lot. many missing tooltips. I will PRs to fix this after the final release of FC 0.18. (Currently I am busy with the installer.)

Kunda1

2019-04-04 13:13

administrator   ~0012995

@uwestoehr awesome. Thanks for all your work on that.

BTW, from a translation POV in regards to line breaks, I am not for adding them. I admin the Crowdin, where FC crowdsources it's translations and many a time translators mess up the whitespace. There are many examples but I don't have time to look for one now.

uwestoehr

2019-04-05 22:42

developer   ~0013000

> in regards to line breaks, I am not for adding them

OK, but how can we manage that the tooltips become readable? Currently the IFC dialog tooltips are much too long for my laptop screen. If no line breaks are allowed, maybe there is an option for a "soft line break" that will automatically break lines if they are on screen longer then e.g. 8 cm?
If there are no soft line breaks I think we must add them manually since unreadable tooltips can be worse than no tooltip.

uwestoehr

2019-07-14 21:20

developer   ~0013344

Last edited: 2019-07-16 01:00

View 4 revisions

With this PR: https://github.com/FreeCAD/FreeCAD/pull/2349 the bug can in my opinion be closed

Related Changesets

FreeCAD: master a2fa902f

2019-07-16 00:57:27

donovaly


Committer: wmayer Details Diff
add and uniform general preferences tooltips Affected Issues
0003866
mod - src/Gui/DlgEditor.ui Diff File
mod - src/Gui/DlgGeneral.ui Diff File
mod - src/Gui/DlgReportView.ui Diff File
mod - src/Gui/DlgSettings3DView.ui Diff File
mod - src/Gui/DlgSettingsDocument.ui Diff File
mod - src/Gui/DlgSettingsMacro.ui Diff File
mod - src/Gui/DlgSettingsUnits.ui Diff File
mod - src/Gui/DlgSettingsViewColor.ui Diff File

Issue History

Date Modified Username Field Change
2019-02-26 09:58 uwestoehr New Issue
2019-03-03 19:16 uwestoehr Note Added: 0012833
2019-03-04 23:26 uwestoehr Note Edited: 0012833 View Revisions
2019-03-06 21:02 uwestoehr Tag Attached: tooltips
2019-03-07 14:01 Kunda1 Note Added: 0012857
2019-03-07 14:01 Kunda1 Note Edited: 0012857 View Revisions
2019-03-07 14:01 Kunda1 Note Edited: 0012857 View Revisions
2019-03-07 23:31 uwestoehr Note Added: 0012859
2019-03-09 19:58 uwestoehr Note Edited: 0012833 View Revisions
2019-03-22 16:32 wmayer Note Added: 0012944
2019-03-31 16:11 Kunda1 Tag Attached: #lowhangingfruit
2019-03-31 16:13 Kunda1 Target Version => 0.19
2019-03-31 16:13 Kunda1 Note Added: 0012979
2019-03-31 16:14 Kunda1 Status new => confirmed
2019-04-01 23:13 uwestoehr Note Added: 0012984
2019-04-04 13:13 Kunda1 Note Added: 0012995
2019-04-05 22:42 uwestoehr Note Added: 0013000
2019-07-14 21:20 uwestoehr Note Added: 0013344
2019-07-14 23:42 uwestoehr Note Edited: 0013344 View Revisions
2019-07-14 23:42 uwestoehr Note Edited: 0013344 View Revisions
2019-07-16 01:00 uwestoehr Note Edited: 0013344 View Revisions
2019-07-16 11:59 wmayer Changeset attached => FreeCAD master a2fa902f
2019-07-16 12:00 wmayer Assigned To => uwestoehr
2019-07-16 12:00 wmayer Status confirmed => closed
2019-07-16 12:00 wmayer Resolution open => fixed