View Issue Details

IDProjectCategoryView StatusLast Update
0003861FreeCADBugpublic2019-03-12 21:55
ReporterfredolcAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindows & MACOSWindows & MACOS VersionWin 10 & Mojave
Product Version0.17 
Target Version0.19Fixed in Version0.19 
Summary0003861: Sketch change plane when changing Attachment Offset (UI quirk)
DescriptionWhen you modify anything in Attactment Offset of a sketch in XZ Plane or YZ Plane, the sketch change to XY Plane.
Steps To ReproduceCreate a sketch in XZ or YZ plane.
Select sketch.
In Data Properties of sketch, click on Attachment Offset.
Modify anything (Translation, Center or Rotation).
Click Ok.
The sketch change its plane (XZ or YZ) to XY plane.
Additional InformationIt was proven in a Windows 10 and MAC Mojave computers.
TagsPlacement, planes, Sketch

Activities

Kunda1

2019-02-25 12:46

administrator   ~0012763

@fredolc Can you recreate this in 0.18dev?
Also in the future please follow our guidelines (large yellow banner at the top of this page) by opening a forum thread to discuss the issue first before opening a ticket.

fredolc

2019-02-25 13:09

reporter   ~0012764

I´ll try it, and I'll inform you.

fredolc

2019-02-25 14:07

reporter   ~0012766

I'd tried with 0,18 dev version for Windows and has the same issue.

wmayer

2019-02-25 16:36

administrator   ~0012768

You forgot to mention a small but important detail: when you edit the Attachment offset parameters directly in the Property Editor then everything is OK.

You run into the issue only when you press the "..." button of the Attachment Offset property which opens a dialog and you change something there.

However, it's only a visual issue. As soon as you modify the sketch after closing the dialog it jumps back to its original plane.

IMO, marking this issue as Crash is absolutely over the top.

fredolc

2019-02-26 16:11

reporter   ~0012774

Ok, I check it and you are right, it's a visual issue, but is difficult to edit the sketch in other plane different to the real, specially when you edit it with other object in the same plane as reference, and when close the sketch, visually, it keeps in the wrong plane, and visually it doesn´t return to the original plane (v0.17). If you extrude the sketch it is done right.

Maybe I catalog bad the issue, I don´t know your issue cataloging system, but I haven´t intended to catalog it as a crash.

wmayer

2019-02-27 18:06

administrator   ~0012782

https://github.com/FreeCAD/FreeCAD/pull/1992
Will be merged after the release of v0.18

uwestoehr

2019-02-28 00:19

developer   ~0012799

Why don't go fixes in for 0.18? I don't see why 0.18 must be frozen even for bugfixes right now.

wmayer

2019-02-28 21:01

administrator   ~0012811

The bug is only a small issue and probably the majority of the users will never see it. However, the required changes are rather big, hence there is a certain chance it causes a regression.
So, it would be risky to merge this so close before the final release.

wmayer

2019-03-12 21:55

administrator   ~0012904

https://github.com/FreeCAD/FreeCAD/commit/8f6bf8eafcaf3dc076f023f9e8ca4791b7aa6be8

Issue History

Date Modified Username Field Change
2019-02-25 08:58 fredolc New Issue
2019-02-25 08:58 fredolc Tag Attached: Placement
2019-02-25 08:58 fredolc Tag Attached: planes
2019-02-25 08:58 fredolc Tag Attached: Sketch
2019-02-25 12:46 Kunda1 Note Added: 0012763
2019-02-25 12:46 Kunda1 Status new => feedback
2019-02-25 13:09 fredolc Note Added: 0012764
2019-02-25 13:09 fredolc Status feedback => new
2019-02-25 14:07 fredolc Note Added: 0012766
2019-02-25 16:36 wmayer Note Added: 0012768
2019-02-25 16:37 wmayer Severity crash => minor
2019-02-26 10:34 Kunda1 Status new => confirmed
2019-02-26 10:34 Kunda1 Target Version => 0.19
2019-02-26 16:11 fredolc Note Added: 0012774
2019-02-26 18:17 Kunda1 Summary Sketch change plane when changing Attachment Offset => Sketch change plane when changing Attachment Offset (UI quirk)
2019-02-27 18:06 wmayer Note Added: 0012782
2019-02-27 20:36 Kunda1 Assigned To => wmayer
2019-02-27 20:36 Kunda1 Status confirmed => assigned
2019-02-28 00:19 uwestoehr Note Added: 0012799
2019-02-28 21:01 wmayer Note Added: 0012811
2019-03-12 21:55 wmayer Status assigned => closed
2019-03-12 21:55 wmayer Resolution open => fixed
2019-03-12 21:55 wmayer Fixed in Version => 0.19
2019-03-12 21:55 wmayer Note Added: 0012904