View Issue Details

IDProjectCategoryView StatusLast Update
0003860FreeCADBugpublic2019-07-29 15:03
ReporterkkremitzkiAssigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.18Fixed in Version0.18 
Summary0003860: Debian bug #920971 - C++ exception on DXF import
DescriptionThe following description is copy+pasted from https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=920971.


I tried to import the file houseplan.dxf
(http://wookware.org/house/houseplan.dxf)
I got this error:
Gui::Command::activated(0): Unknown C++ exception thrown

However I did also get a model containing Shape001 to Shape2829 which
all appear to be individual lines (so that's probably correct as
'Create simple part shapes' was selected in the import preferences
dialog). Not very useful but 'correct' :-)

The exception seems bad though. Possibly this bug should be redirected
to the DXF parsing library, but I'm not sure which one is in use.

Wookey
TagsNo tags attached.

Activities

wmayer

2019-02-25 22:46

administrator   ~0012769

What happens is that inside OnReadArc the three parameters s, e, and c are identical and thus creates a degenerate arc, i.e. start and end point and center of the arc collapse to a single point.

Then of course OCCT raises an error because it cannot create a shape from the geometry. This exception isn't handled locally so that it goes up to Gui::Command::invoke.

wmayer

2019-02-25 22:48

administrator   ~0012770

https://github.com/FreeCAD/FreeCAD/commit/d3e008e46cdb48ddf33d8e238d4893679cf2bc92

Related Changesets

FreeCAD: releases/FreeCAD-0-18 d3e008e4

2019-02-25 22:46:31

wmayer

Details Diff
fixes 0003860: Debian bug #920971 - C++ exception on DXF import Affected Issues
0003860
mod - src/Mod/Import/App/AppImportPy.cpp Diff File
mod - src/Mod/Import/App/ImpExpDxf.cpp Diff File

Issue History

Date Modified Username Field Change
2019-02-25 02:26 kkremitzki New Issue
2019-02-25 21:58 wmayer Target Version => 0.18
2019-02-25 22:46 wmayer Note Added: 0012769
2019-02-25 22:48 wmayer Assigned To => wmayer
2019-02-25 22:48 wmayer Status new => closed
2019-02-25 22:48 wmayer Resolution open => fixed
2019-02-25 22:48 wmayer Fixed in Version => 0.18
2019-02-25 22:48 wmayer Note Added: 0012770
2019-07-29 15:03 Kunda1 Changeset attached => FreeCAD releases/FreeCAD-0-18 d3e008e4