View Issue Details

IDProjectCategoryView StatusLast Update
0003845PartDesignBugpublic2019-02-19 08:52
ReporteruwestoehrAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target VersionFixed in Version0.18 
Summary0003845: unwanted rounding for dimensions of subtractive shapes in task dialog
DescriptionThe radius of a subtractive cylinder. Its radius should be exactly 0.525 mm.
But as you can see in the attached simple example. I can set the radius to 0.525 but after I pressed OK and then subsequently double-click in the cylinder whose radius I just set I see again 0.53

I use already 3 digits in the FC preferences and also using 4 digits does not solve my problem.

It turned out that this is an issue of the task dialog because when you edit the radius directly in the Data tab of the combo view, I get the value I want.
Additional Informationforum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=34292

OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15860 (Git)
Build type: Release
Branch: master
Hash: 3b708c7f84b0425076b520e1d95627b20fd75fe0
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)
TagsNo tags attached.

Activities

uwestoehr

2019-02-18 15:40

developer   ~0012676

This is not only a display issue since the unwanted rounding appears also in a Techdraw drawing.

wmayer

2019-02-19 08:52

administrator   ~0012682

https://github.com/FreeCAD/FreeCAD/commit/638845a6f0159514ecf73813027b54197b1c3e7b

Issue History

Date Modified Username Field Change
2019-02-18 14:20 uwestoehr New Issue
2019-02-18 15:40 uwestoehr Note Added: 0012676
2019-02-19 08:46 wmayer Severity tweak => minor
2019-02-19 08:52 wmayer Assigned To => wmayer
2019-02-19 08:52 wmayer Status new => closed
2019-02-19 08:52 wmayer Resolution open => fixed
2019-02-19 08:52 wmayer Fixed in Version => 0.18
2019-02-19 08:52 wmayer Note Added: 0012682