View Issue Details

IDProjectCategoryView StatusLast Update
0003835FreeCADBugpublic2019-02-14 11:37
Reporteruwestoehr Assigned Towmayer  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target VersionFixed in Version0.18 
Summary0003835: FC freezes when editing export STEP preferences
Description- start FC
- use the Part WB or PartDesign WB
- use menu Edit -> Preferences -> Import-Export -> STEP
- there write into the 'author' field text with an umlaut, e.g. 'stöhr"
- press Apply

result: FC freezes. There is no output in the message panel. Finally one has to kill FC because it is not responding and unusable, no matter how long you wait. It seems to be an unfinished loop because the FC uses the full CPU power of one CPU core as soon as you press Apply.
There is no but if there is no umlaut in the author field. Interestingly other non-ASCII characters don't trigger the freeze, e.g. using 'µ' or '³' work. However since my name contains an umlaut I want to use it of course. If this is not possible FC must tell me about and prevent the input of not allowed character.
Additional Informationconfirmed by 2 other users, forum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=34180

FreeCAD: 64-bit
Version: 0.18.15860 (Git)
TagsNo tags attached.
FreeCAD Information

Issue History

Date Modified Username Field Change
2019-02-14 11:34 uwestoehr New Issue
2019-02-14 11:37 wmayer Assigned To => wmayer
2019-02-14 11:37 wmayer Status new => closed
2019-02-14 11:37 wmayer Resolution open => fixed
2019-02-14 11:37 wmayer Fixed in Version => 0.18
2019-02-14 11:37 wmayer Note Added: 0012634