View Issue Details

IDProjectCategoryView StatusLast Update
0003823FEM[FreeCAD] Bugpublic2019-02-18 22:27
ReporteruwestoehrAssigned Towmayer 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.18 
Target VersionFixed in Version[FreeCAD] 0.18 
Summary0003823: FEM, unusable material property changing when using task panel
Descriptionusing the option "use this task panel" it is very hard to change or enter values:

- add a material, then check the option "use this task panel"

For example in the density field you have "1250,00 kg/m^3". You want to change it to "1700,00 kg/m^3"

- therefore highlight in the field the numbers "25" and type in "70"

result: you get "170,00 kg/m^30" which is an illegal value.

Now assume you want to change the poisson ratio to "0,48"

- thus highlight the complete field for the poisson ratio and type in "0,48"

result: you get "0,000"

- now set the cursor in the poisson ratio field behind the comma and type in e.g. "48"

result: noting happens

The problem is that FC evaluates the input after every key press. This cannot work. It must allow the user to enter and edit numbers as he likes and first when the user clicked on the check mark in the field its content is evaluated. if there is a mistake the field should be highlighted red.
Additional InformationAs discussed here: https://forum.freecadweb.org/viewtopic.php?f=38&t=34017

The feature to change material properties via the task panel should be removed.
Tagsmaterial

Issue History

Date Modified Username Field Change
2019-02-08 23:10 uwestoehr New Issue
2019-02-08 23:10 uwestoehr Tag Attached: material
2019-02-17 21:52 berndhahnebach Summary unusable material property changing when using task panel => FEM, unusable material property changing when using task panel
2019-02-18 12:52 berndhahnebach Project FreeCAD => FEM
2019-02-18 18:37 wmayer Status new => confirmed
2019-02-18 22:27 wmayer Assigned To => wmayer
2019-02-18 22:27 wmayer Status confirmed => closed
2019-02-18 22:27 wmayer Resolution open => fixed
2019-02-18 22:27 wmayer Fixed in Version => 0.18
2019-02-18 22:27 wmayer Note Added: 0012678