View Issue Details

IDProjectCategoryView StatusLast Update
0003805FreeCADBugpublic2019-02-21 17:50
Reportermarkus51Assigned Towmayer 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformOSWin7OS Version
Product Version0.17 
Target VersionFixed in Version0.18 
Summary0003805: After "Create a hole with the selected sketch" the model disapers
DescriptionSometimes when i use "Create a hole with the selected sketch" in the "Part Design"
the model disapers after the call.

*) The sketch is on the correct plane
*) In a previously state the same setting of "Create a hole with the selected sketch"
   working fine.
*) When i remove the current hole item, and create a hole item with the same settings,
   all works fine.
Steps To Reproduce1.) Open "Error-BaseHoles002.FCStd" with FreeCAD 0.17 (Revisionnamber 13541)
2.) Goto PartDesign
3.) Open the "Combo-View" at "Model"
4.) Do a double click on the sketch "BaseHoles002S"
5.) You see the sketch is on correct plane
6.) Close the sketch
7.) Do a double click on the hole item "BaseHoles002" and press "OK"
8.) The model disapears
9.) Goto "Combo-View / Model"
10.) Select the hole item "BaseHoles002"
11.) Press DEL and remove "BaseHoles002"
12.) Select the the sketch "BaseHoles002S"
13.) Press in the toolbar "Create a hole with the selected sketch"
14.) Input the same hole parameters
       - Diameter=8
       - Type=CounterSink
       - Type/Diameter=Settings.SinkDiameter
15.) Press OK above the "Hole Parameters"
16.) The new hole item works fine, but it has the same parameters as the old one
     which didn't worked. (see Info.png)


TagsNo tags attached.

Activities

markus51

2019-01-27 21:25

reporter  

Error-BaseHoles002.FCStd (228,988 bytes)
Info.png (77,594 bytes)
Info.png (77,594 bytes)

markus51

2019-01-28 12:49

reporter   ~0012541

The same problem exists on version 0.18dev

Kunda1

2019-01-29 18:16

administrator   ~0012552

Where is the forum post discussing this with the community?
Please follow the tracker guidelines. Thanks you for your comprehension

CC @wmayer care to weigh in?

wmayer

2019-02-21 17:00

administrator   ~0012715

This is not a bug at all. In the model tree you have made visible the object ProfilLands002 instead of BaseHoles002.

wmayer

2019-02-21 17:03

administrator   ~0012716

The only issue is that when double-clicking BaseHoles002 and pressing OK that it doesn't show the model. This is only very minor issue.

wmayer

2019-02-21 17:50

administrator   ~0012717

https://github.com/FreeCAD/FreeCAD/commit/2fcb7cb644a866a01532c82065a7a2433239b60e

Issue History

Date Modified Username Field Change
2019-01-27 21:25 markus51 New Issue
2019-01-27 21:25 markus51 File Added: Error-BaseHoles002.FCStd
2019-01-27 21:25 markus51 File Added: Info.png
2019-01-28 12:49 markus51 Note Added: 0012541
2019-01-29 18:16 Kunda1 Note Added: 0012552
2019-01-29 18:16 Kunda1 Status new => feedback
2019-02-21 17:00 wmayer Note Added: 0012715
2019-02-21 17:03 wmayer Severity major => tweak
2019-02-21 17:03 wmayer Note Added: 0012716
2019-02-21 17:50 wmayer Assigned To => wmayer
2019-02-21 17:50 wmayer Status feedback => closed
2019-02-21 17:50 wmayer Resolution open => fixed
2019-02-21 17:50 wmayer Fixed in Version => 0.18
2019-02-21 17:50 wmayer Note Added: 0012717