View Issue Details

IDProjectCategoryView StatusLast Update
0003804FEM[FreeCAD] Bugpublic2019-02-15 22:31
ReporteruwestoehrAssigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.18 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003804: FC becomes unusable after double-cicking on FEM elements while clip view is active
DescriptionI found a bug in FC 64-bit Version: 0.18.15711 (Windows build)

To reproduce:
- create a new document, there create a simple body, e.g. a block
- create a new simulation
- now use the menu View -> Clipping plane and clip e.g. along Z
important is that you keep the clipping dialog open!
- now go to the Model tab and double-click on "CalculiXccxTools"

result: you get correctly the message that there is a dialog active

- so now go to the Tasks tab and close the clipping view

result: you still cannot do anything. No matter what FEM element you like to modify, meshes, constraints etc., every time you still get the error that a Task dialog is already open. But this is not the case.
Thus to be able to to something with FC, I have to close my document.

After long time fiddling around I just found a workaround: I can open a sketch, do nothing but close the sketch task dialog and eventually FC is working again also for FEM elements.
Additional InformationForum thread: https://forum.freecadweb.org/viewtopic.php?p=282805
TagsFEM

Activities

berndhahnebach

2019-01-31 17:20

developer   ~0012567

confirmed!

you can even see it better on a simple part and a gmsh object.

- make a part box
- mesh this box with gmsh obj
- use the view clipping plane
- leave Tasks tab without closing it
- double click on the gmsh obj
- the error mesage comes up
- close the tasks panel
- try double click on the gmsh obj
- it is in edit mode

- here you can finish the edition with right click, but it is still some how in editing.

What happens seams to be on double click on an obj. which is python based when the clipping plan is open it does somehow sets the python obj in edit mode, but does not close the clipping view. Thus two objts are somehow in an edit mode which is not possible.

Either the python obj. should not go in edit mode at all or the clipping plan shoud leave the edit mode. This is what happens with a pop up with C++ based objects like the constraints force. Try to click on such an obj when in clipping plane mode.

mhh IMHO this seams a case for werner.

cheers bernd

Kunda1

2019-02-01 11:07

administrator   ~0012572

berndhahnebach wrote

mhh IMHO this seams a case for werner.

Assigning to wmayer

berndhahnebach

2019-02-02 22:45

developer   ~0012578

I have been in contact with werner in this regard. He might have a look at this.

berndhahnebach

2019-02-10 08:26

developer   ~0012603

Relted to this ...
we had lots of dsscussions about the clipping. For FEM it sould be very very useful if the clipping would not be in the task panel and thus blocks the task panel. This because the clipping is needed while editing contraint objects.

wmayer

2019-02-15 22:31

administrator   ~0012660

https://github.com/FreeCAD/FreeCAD/commit/645b397dda35b19ef6f2a4abd8cc94be19743159

Issue History

Date Modified Username Field Change
2019-01-27 21:15 uwestoehr New Issue
2019-01-27 21:15 uwestoehr Tag Attached: FEM
2019-01-29 18:21 Kunda1 Assigned To => berndhahnebach
2019-01-29 18:21 Kunda1 Status new => confirmed
2019-01-29 18:21 Kunda1 Target Version => 0.18
2019-01-31 17:20 berndhahnebach Note Added: 0012567
2019-02-01 11:06 Kunda1 Assigned To berndhahnebach => wmayer
2019-02-01 11:07 Kunda1 Note Added: 0012572
2019-02-02 22:45 berndhahnebach Note Added: 0012578
2019-02-10 08:26 berndhahnebach Note Added: 0012603
2019-02-15 22:31 wmayer Status confirmed => closed
2019-02-15 22:31 wmayer Resolution open => fixed
2019-02-15 22:31 wmayer Fixed in Version => 0.18
2019-02-15 22:31 wmayer Note Added: 0012660