View Issue Details

IDProjectCategoryView StatusLast Update
0000038FreeCADBugpublic2009-12-14 18:23
ReporteryorikAssigned Toyorik 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000038: funny qt graphical artifact in preferences screen
DescriptionThis is really not important at all because it is only esthetic, the functionning is not affected. But I noticed since a couple of days that the modules buttons on the preference screen now appear "scrambled"... (see attached screenshot).

I think I didn't change anything special on my system, so thought maybe one of you would have an idea...

I'm not totally sure it's a freecad bug, so if it looks irrelevant to you, don't hesitate to close this bug ok? I just thought maybe one of you would immediately know what this is...

Cheers
Yorik
TagsNo tags attached.

Activities

2009-11-08 03:07

 

strange-qt-bug.jpg (Attachment missing)

wmayer

2009-11-09 18:37

administrator   ~0000032

For me everything is OK. And to be honest I don't really understand what's wrong with your preferences icons.

BTW, do you have a modified FreeCAD version running as you have another application icon than the default one?

2009-11-09 18:53

 

prefscreen-bug.jpg (Attachment missing)

yorik

2009-11-09 18:59

administrator   ~0000033

Yes, you are right, my screenshot was bad. Look at this new one... It happens easier if I open/close the pref window a couple of times.
But really I don't know if it's freecad or something else causing it.

About the app icon, it's this one: http://sourceforge.net/apps/mediawiki/free-cad/index.php?title=File:FreeCAD05.svg
What do you think of it?

wmayer

2009-11-09 19:17

administrator   ~0000034

OK, this clearly shows the issue. I opened the dialog many times but it always worked for me. What is your current OS? Still Ubuntu or Debian testing?

Yes, the application looks quite nice. IMO we could replace the old one.

yorik

2009-11-09 19:40

administrator   ~0000035

Yes, debian testing (I falled in love with debian :)

Then it's probably specific on my system. I really must test a bit more, I'll look at the code and try to make another small app with same kind of button. Let's keep this issue open until I find out more, okay? I assigned it to myself...

yorik

2009-12-13 16:56

administrator   ~0000063

I tried building a small pyqt application that uses exactly the same widgets and icons as the preference screen, but everything works absolutely normally. I'll do one more test then if I have no more idea I'll close this bug, since nobody else has that problem.

unauthenticated

2009-12-14 08:28

viewer   ~0000064

On my Debian testing system I have exactly the same problem. The funny thing is when redirecting the display to a remote X server everything seems to work fine.

Could you please share the pyqt test application with me so that can I see if it works for me, too?

Werner

2009-12-14 12:58

 

testdialog.py (Attachment missing)

yorik

2009-12-14 12:59

administrator   ~0000068

Sure, here it goes (see latest attachment)
It's a simple dialog with a ListWidget where you can add icons. The definition of the listwidget is copied from the FreeCAD preference dialog ui file...

wmayer

2009-12-14 18:23

administrator   ~0000069

Thanks, Yorik. It's fixed in 2739.

Issue History

Date Modified Username Field Change
2009-11-08 03:07 yorik New Issue
2009-11-08 03:07 yorik File Added: strange-qt-bug.jpg
2009-11-09 18:37 wmayer Note Added: 0000032
2009-11-09 18:53 yorik File Added: prefscreen-bug.jpg
2009-11-09 18:59 yorik Note Added: 0000033
2009-11-09 19:17 wmayer Note Added: 0000034
2009-11-09 19:39 yorik Status new => assigned
2009-11-09 19:39 yorik Assigned To => yorik
2009-11-09 19:40 yorik Note Added: 0000035
2009-12-13 16:56 yorik Note Added: 0000063
2009-12-14 08:28 unauthenticated Note Added: 0000064
2009-12-14 12:58 yorik File Added: testdialog.py
2009-12-14 12:59 yorik Note Added: 0000068
2009-12-14 18:23 wmayer Note Added: 0000069
2009-12-14 18:23 wmayer Status assigned => closed
2009-12-14 18:23 wmayer Resolution open => fixed