View Issue Details

IDProjectCategoryView StatusLast Update
0003781FEM[FreeCAD] Bugpublic2019-02-11 06:46
Reporteruwestoehr Assigned Toberndhahnebach  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version[FreeCAD] 0.18 
Target VersionFixed in Version 
Summary0003781: Material Editor, Value gets lost and wrong unit mismatch
Description- open the material editor
- try to edit/change the specific heat by clicking on the entry

result: the value will be deleted to zero and the unit is wrong, see the attached screenshots (the correct unit is J/kg/K <-> m/(s^2*K)). As final result, no matter what value you insert, it won't be taken for the material. There you get always 0 J/kg/K.

The workaround is to input the correct unit manually.

This bug only happens for the specific heat.
Tagsmaterial

Activities

uwestoehr

2019-01-20 03:25

developer  

Specific-Heat-1.jpg (76,511 bytes)
Specific-Heat-1.jpg (76,511 bytes)
Specific-Heat-2.jpg (78,981 bytes)
Specific-Heat-2.jpg (78,981 bytes)

Kunda1

2019-01-22 23:37

administrator   ~0012492

@uwestoehr please follow the guidelines (enormous yellow banner at the top of the page) when opening tickets. There is no extensive FC version info, no forum thread. Please open a thread to discuss this with bernd, the FEM maintainer

uwestoehr

2019-01-23 23:31

developer   ~0012502

> There is no extensive FC version info

@Kunda1, I specified that I use version 0.18, see this bug report header. I also use the latest development snapshot as given in the yellow banner when reporting bugs.

> no forum thread. Please open a thread to discuss this with bernd, the FEM maintainer.

Sorry, but I don't have that much time. I reported a bug I saw and checked that it is not yet reported as best as possible. feel free to ignore my bug reports or close them immediately if you don't think it is a real bug.

I am an Open Source software developer too and know that some bug reports are not valid, thus I checked carefully not to report already existing issues. But you cannot expect people to discuss at first in a forum - waiting for replies, respond, waiting again... So I collected all bugs I found and reported them that they are not forgotten. (I don't use FC regularly, maybe once a month.)

Kunda1

2019-01-25 17:18

administrator   ~0012509

@uwestoehr Please understand the context FC doesn't use the bugtracker like a conventional open or proprietary project uses one. The forum gets the most traffic and many bugs get solved before they need a ticket. I acknowledge the work it takes to register, login, open a ticket etc..etc..

I don't doubt in your case you didn't do you due-diligence (that you are used to) but if you read our guidelines you'd know for example that posting version 0.18 is not enough, there are many issues with 3rd party dependencies and FC. Also 0.18_pre is a rapidly evolving beast hence we ask everyone to post their full version info (as per the guidelines) which can be found in Help > About FreeCAD > Copy to clipboard. By posting this info you save the devs/testers/triagers extra time in understanding the issue.

Thank you for your comprehension

Kunda1

2019-01-25 17:20

administrator   ~0012510

Deferring to @berndhahnebach

berndhahnebach

2019-01-26 21:13

developer   ~0012524

Last edited: 2019-01-26 21:13

View 2 revisions

seams exact the same as this post ... https://forum.freecadweb.org/viewtopic.php?f=38&p=278080#p278080

The material editor got some heavy changes in the regard of units ...

berndhahnebach

2019-01-26 21:21

developer   ~0012526

It is not really a FEM problem since the material editor is independent of FEM. But since the specific heat is used in FEM only ATM we should leave it on FEM ...

I may have a look at this ...

bernd

berndhahnebach

2019-02-02 22:33

developer   ~0012576

thanks for reporting uwe ...

https://github.com/FreeCAD/FreeCAD/pull/1944/commits/1cb4c0d478ff127fc58d08ef0ec776c06ab8ad48

berndhahnebach

2019-02-02 22:41

developer   ~0012577

the mismatch ...

https://github.com/FreeCAD/FreeCAD/blob/f94e76c1116ec3b818961ff65131b3d86fa5b95e/src/Base/Unit.cpp#L487
https://github.com/FreeCAD/FreeCAD/blob/f94e76c1116ec3b818961ff65131b3d86fa5b95e/src/Mod/Material/MatPropDict.xml#L66


related: https://forum.freecadweb.org/viewtopic.php?f=38&p=284126#p284126

uwestoehr

2019-02-08 23:57

developer   ~0012594

This bug I reported initially was meanwhile fixed by:
https://github.com/FreeCAD/FreeCAD/commit/f05d8c314a00daf762c9a3ee58d9857b36056c8f

So this bug should be marked as fixed and a new bug should be opened for the unit mismatch issue.

Kunda1

2019-02-09 11:04

administrator   ~0012596

Last edited: 2019-02-10 23:32

View 2 revisions

@berndhahnebach
I just renamed the ticket to also reflect the 'mismatch' so when the time comes for the fix you can add the git commit here and close the ticket ;)

berndhahnebach

2019-02-11 06:44

developer   ~0012620

f05d8c3

berndhahnebach

2019-02-11 06:46

developer   ~0012621

https://github.com/FreeCAD/FreeCAD/commit/f05d8c3

Issue History

Date Modified Username Field Change
2019-01-20 03:25 uwestoehr New Issue
2019-01-20 03:25 uwestoehr File Added: Specific-Heat-1.jpg
2019-01-20 03:25 uwestoehr File Added: Specific-Heat-2.jpg
2019-01-22 23:37 Kunda1 Status new => feedback
2019-01-22 23:37 Kunda1 Note Added: 0012492
2019-01-23 23:31 uwestoehr Note Added: 0012502
2019-01-23 23:31 uwestoehr Status feedback => new
2019-01-25 17:18 Kunda1 Note Added: 0012509
2019-01-25 17:19 Kunda1 Assigned To => berndhahnebach
2019-01-25 17:19 Kunda1 Status new => assigned
2019-01-25 17:20 Kunda1 Note Added: 0012510
2019-01-26 21:13 berndhahnebach Note Added: 0012524
2019-01-26 21:13 berndhahnebach Note Edited: 0012524 View Revisions
2019-01-26 21:20 berndhahnebach Summary Value gets lot and wrong unit in FEM material editor => Material Editor, Value gets lost and wrong unit
2019-01-26 21:21 berndhahnebach Note Added: 0012526
2019-01-27 15:05 uwestoehr Tag Attached: material
2019-02-02 22:33 berndhahnebach Note Added: 0012576
2019-02-02 22:41 berndhahnebach Note Added: 0012577
2019-02-08 23:57 uwestoehr Note Added: 0012594
2019-02-09 11:03 Kunda1 Summary Material Editor, Value gets lost and wrong unit => Material Editor, Value [s]gets lost and wrong unit[s] mismatch
2019-02-09 11:03 Kunda1 Summary Material Editor, Value gets lost and wrong unit[s] mismatch => Material Editor, Value [s]gets lost and wrong unit mismatch
2019-02-09 11:04 Kunda1 Note Added: 0012596
2019-02-10 23:32 Kunda1 Note Edited: 0012596 View Revisions
2019-02-11 06:44 berndhahnebach Note Added: 0012620
2019-02-11 06:44 berndhahnebach Status assigned => closed
2019-02-11 06:44 berndhahnebach Resolution open => fixed
2019-02-11 06:46 berndhahnebach Status closed => feedback
2019-02-11 06:46 berndhahnebach Resolution fixed => reopened
2019-02-11 06:46 berndhahnebach Status feedback => closed
2019-02-11 06:46 berndhahnebach Note Added: 0012621