View Issue Details

IDProjectCategoryView StatusLast Update
0003767FreeCADBugpublic2019-01-16 20:46
Reporternarf Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSKubuntuOS Version18.10
Product Version0.18 
Target VersionFixed in Version 
Summary0003767: Addon Manager does not start
DescriptionTrying tu run Addon Manager yields error message (console output), no addon manager opens:


Running the Python command 'Std_AddonMgr' failed:
Traceback (most recent call last):
  File "/usr/lib/freecad-daily/Mod/AddonManager/AddonManagerGui.py", line 10, in Activated
    import AddonManager
  File "/usr/lib/freecad-daily/Mod/AddonManager/AddonManager.py", line 46, in <module>
    from PySide import QtCore, QtGui
  File "/usr/lib/freecad-daily/Ext/PySide/QtCore.py", line 1, in <module>
    from PySide2.QtCore import *

/usr/lib/python2.7/dist-packages/PySide2/QtCore.x86_64-linux-gnu.so: undefined symbol: _Z23init_QRandomGenerator64P7_object
Steps To ReproduceHit "Tools" --> Addon Manager. No addon manager opens, but error message is displayed.
Additional InformationOS: Ubuntu 18.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15592 (Git)
Build type: Release
Branch: master
Hash: a7c0f4bc5b62ec304a5855796ca3d10a42c7a46e
Python version: 2.7.15+
Qt version: 5.11.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

I tried with daily version before (this one), then updated to current daily - same result.
Tagsaddon-manager

Activities

narf

2019-01-09 21:22

reporter   ~0012407

Version info was misunderstanable, sorry. I wanted to say:

Version: 0.18.15592 (Git)
Build type: Release
Branch: master
Hash: a7c0f4bc5b62ec304a5855796ca3d10a42c7a46e

I tried with daily version before that one (from yesterday), then updated to current daily (version information above)- same result.

Kunda1

2019-01-11 11:18

administrator   ~0012411

Can't recreate on the latest appimage

OS: "Manjaro Linux"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15609 (Git) AppImage
Build type: Release
Branch: master
Hash: a14af0f2bd26f980d71be80a799ee48127bc7619
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

@narf how did you build FreeCAD ?

ivantaran

2019-01-13 19:10

reporter   ~0012425

Similiar problem when switching from Part to Path.

/usr/lib/python2.7/dist-packages/PySide2/QtCore.x86_64-linux-gnu.so: undefined symbol: _Z23init_QRandomGenerator64P7_object

OS: Ubuntu 18.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15611 (Git)
Build type: Release
Branch: master
Hash: 64a94ae0f7c60fc981086fe157150a9c0dca29c6
Python version: 2.7.15+
Qt version: 5.11.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

narf

2019-01-16 20:24

reporter   ~0012446

Sorry for the late reply.

I did just update to the current freecad-daily version from ubuntu repository. The issue is gone. Still, thanks for trying to reproduce!

Best Regards

OS: Ubuntu 18.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15611 (Git)
Build type: Release
Branch: master
Hash: 64a94ae0f7c60fc981086fe157150a9c0dca29c6
Python version: 2.7.15+
Qt version: 5.11.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

Kunda1

2019-01-16 20:46

administrator   ~0012447

Last edited: 2019-01-16 20:46

View 2 revisions

@ivantaran please test with the latest built and if it continues post your issue to the forum as this seems to be separate issue from what the original ticket was opened for.
Closing this ticket.

Issue History

Date Modified Username Field Change
2019-01-09 21:20 narf New Issue
2019-01-09 21:20 narf Tag Attached: addon-manager
2019-01-09 21:22 narf Note Added: 0012407
2019-01-11 11:18 Kunda1 Note Added: 0012411
2019-01-11 11:18 Kunda1 Status new => feedback
2019-01-13 19:10 ivantaran File Added: Screenshot from 2019-01-13 22-03-49.png
2019-01-13 19:10 ivantaran Note Added: 0012425
2019-01-16 20:24 narf Note Added: 0012446
2019-01-16 20:24 narf Status feedback => new
2019-01-16 20:46 Kunda1 Status new => closed
2019-01-16 20:46 Kunda1 Resolution open => no change required
2019-01-16 20:46 Kunda1 Note Added: 0012447
2019-01-16 20:46 Kunda1 Note Edited: 0012447 View Revisions