View Issue Details

IDProjectCategoryView StatusLast Update
0003766TechDraw[FreeCAD] Bugpublic2019-01-09 21:10
Reportersliptonic Assigned Towmayer  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.18 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003766: Closing and re-opening a TechDraw page causes segfault
Descriptionhttps://forum.freecadweb.org/viewtopic.php?f=35&t=33341

Reopening a closed TechDraw drawing MDI page causes a segfault.
Steps To ReproduceCreate a new TechDraw Page.
Add some views.
Close the MDI Page window.
Double click to re-open the page.

Additional InformationIf the document is saved with the page open, it will be restored on open and continue to work. It's only if the MDI window is closed and reopened.
TagsNo tags attached.
FreeCAD Information

Activities

Kunda1

2019-01-09 20:48

administrator   ~0012405

Punted to wmayer since it's a serious bug.

wmayer

2019-01-09 21:10

administrator   ~0012406

https://github.com/FreeCAD/FreeCAD/commit/356ecd5b1bcab81bb8fbe7811c9ba7c7dc0ca547

Issue History

Date Modified Username Field Change
2019-01-09 20:43 sliptonic New Issue
2019-01-09 20:47 Kunda1 Assigned To => wmayer
2019-01-09 20:47 Kunda1 Status new => assigned
2019-01-09 20:48 Kunda1 Note Added: 0012405
2019-01-09 21:10 wmayer Status assigned => closed
2019-01-09 21:10 wmayer Resolution open => fixed
2019-01-09 21:10 wmayer Fixed in Version => 0.18
2019-01-09 21:10 wmayer Note Added: 0012406