View Issue Details

IDProjectCategoryView StatusLast Update
0003748PartDesignBugpublic2019-02-24 16:28
ReporterFrankBlabuAssigned Tonormandc 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformDell XPS laptopOSLinux MintOS Version19.1
Product Version0.18 
Target VersionFixed in Version 
Summary0003748: Crash when creating a new body
DescriptionSoftware crashes everytime a new part is created in the part design workspace.
Steps To Reproduce
  1. Start SW
  2. Switch into part design workspace
  3. Choose "Create a new empty project" from toolbar
  4. Choose "Create body" from the tasks


--> Crash
Additional Information
  1. Latest version from git repository: FreeCAD 0.18, Libs: 0.18R15496
  2. Crash message:
    
    FreeCAD: SoType.cpp:739: SbBool SoType::isDerivedFrom(SoType) const: Assertion `!this->isBad()' failed.
    
    
    
  3. Backtrace:
    
    #0  0x00007ffff44f4e97 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
    #1  0x00007ffff44f6801 in __GI_abort () at abort.c:79
    0000002  0x00007ffff44e639a in __assert_fail_base (fmt=0x7ffff466d7d8 "%s%s%s:%u: %s%sAssertion `%s' 
    
    failed.\n%n", assertion=assertion@entry=0x7ffff409c2f9 "!this->isBad()", file=file@entry=0x7ffff409c2d9 
    
    "SoType.cpp", line=line@entry=739, function=function@entry=0x7ffff409c720 "SbBool SoType::isDerivedFrom(SoType) 
    
    const") at assert.c:92
    0000003  0x00007ffff44e6412 in __GI___assert_fail (assertion=0x7ffff409c2f9 "!this->isBad()", 
    
    file=0x7ffff409c2d9 "SoType.cpp", line=739, function=0x7ffff409c720 "SbBool SoType::isDerivedFrom(SoType) 
    
    const") at assert.c:101
    0000004  0x00007ffff3d79718 in SoType::isDerivedFrom(SoType) const () at /usr/lib/x86_64-linux-gnu/libCoin.so.80
    
    
    0000005  0x00007ffff3d56aad in SoBase::isOfType(SoType) const () at /usr/lib/x86_64-linux-gnu/libCoin.so.80
    
    
    0000006  0x00007ffff3d69ba1 in SoNotList::append(SoNotRec*) () at /usr/lib/x86_64-linux-gnu/libCoin.so.80
    
    
    0000007  0x00007ffff3cd2707 in SoField::notify(SoNotList*) () at /usr/lib/x86_64-linux-gnu/libCoin.so.80
    
    
    0000008  0x00007ffff3cd1edb in SoField::valueChanged(int) () at /usr/lib/x86_64-linux-gnu/libCoin.so.80
    0000009  0x00007fff67bc38e4 in PartGui::SoBrepFaceSet::SoBrepFaceSet() ()
        at /home/frank/Projects/freecad-build/Mod/Part/PartGui.so
    0000010 0x00007fff67bcab7c in PartGui::ViewProviderPartExt::ViewProviderPartExt() ()
        at /home/frank/Projects/freecad-build/Mod/Part/PartGui.so
    0000011 0x00007fff67bc70b9 in PartGui::ViewProviderPart::ViewProviderPart() ()
        at /home/frank/Projects/freecad-build/Mod/Part/PartGui.so
    0000012 0x00007fff7860599a in PartDesignGui::ViewProviderBody::ViewProviderBody() ()
        at /home/frank/Applications/FreeCAD/Mod/PartDesign/PartDesignGui.so
    0000013 0x00007fff78605aeb in PartDesignGui::ViewProviderBody::create() ()
        at /home/frank/Applications/FreeCAD/Mod/PartDesign/PartDesignGui.so
    0000014 0x00007ffff66de14c in Base::Type::createInstanceByName(char const*, bool) ()
        at /home/frank/Projects/freecad-build/lib/libFreeCADBase.so
    0000015 0x00007ffff728770d in Gui::Document::slotNewObject(App::DocumentObject const&) ()
        at /home/frank/Projects/freecad-build/lib/libFreeCADGui.so
    0000016 0x00007ffff6af7e79 in boost::signals2::detail::signal_impl<void (App::DocumentObject const&), 
    
    boost::signals2::optional_last_value<void>, int, std::less<int>, boost::function<void 
    
    (App::DocumentObject const&)>, boost::function<void (boost::signals2::connection const&, 
    
    App::DocumentObject const&)>, boost::signals2::mutex>::operator()(App::DocumentObject const&) 
    
    () at /home/frank/Projects/freecad-build/lib/libFreeCADApp.so
    0000017 0x00007ffff6ac3aaa in App::Document::addObject(char const*, char const*, bool) ()
        at /home/frank/Projects/freecad-build/lib/libFreeCADApp.so
    0000018 0x00007ffff6b3943c in App::DocumentPy::addObject(_object*) ()
        at /home/frank/Projects/freecad-build/lib/libFreeCADApp.so
    ---Type <return> to continue, or q <return> to quit---
    0000019 0x00007ffff6b39f57 in App::DocumentPy::staticCallback_addObject(_object*, _object*) ()
        at /home/frank/Projects/freecad-build/lib/libFreeCADApp.so
    0000020 0x00007ffff60de1d0 in PyEval_EvalFrameEx () at /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0
    0000021 0x00007ffff620e278 in PyEval_EvalCodeEx () at /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0
    0000022 0x00007ffff60d6029 in PyEval_EvalCode () at /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0
    0000023 0x00007ffff6179546 in PyRun_StringFlags () at /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0
    0000024 0x00007ffff6675966 in Base::InterpreterSingleton::runString[abi:cxx11](char const*) ()
        at /home/frank/Projects/freecad-build/lib/libFreeCADBase.so
    0000025 0x00007ffff72e4c33 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) ()
        at /home/frank/Projects/freecad-build/lib/libFreeCADGui.so
    0000026 0x00007fff7857185b in CmdPartDesignBody::activated(int) ()
        at /home/frank/Applications/FreeCAD/Mod/PartDesign/PartDesignGui.so
    0000027 0x00007ffff72ea06b in Gui::Command::invoke(int) () at /home/frank/Projects/freecad-build/lib/libFreeCADGui.so
    
    
    0000028 0x00007ffff4fe6f70 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) ()
        at /usr/lib/x86_64-linux-gnu/libQtCore.so.4
    0000029 0x00007ffff54f8dc2 in QAction::triggered(bool) () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    0000030 0x00007ffff54fa113 in QAction::activate(QAction::ActionEvent) () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    
    
    0000031 0x00007ffff58dafa3 in  () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    0000032 0x00007ffff58db0f4 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) ()
        at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    0000033 0x00007ffff59a10aa in QToolButton::mouseReleaseEvent(QMouseEvent*) () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    
    
    0000034 0x00007ffff5555930 in QWidget::event(QEvent*) () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    0000035 0x00007ffff54ff03c in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
        at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    0000036 0x00007ffff5506136 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    
    
    0000037 0x00007ffff72bd558 in Gui::GUIApplication::notify(QObject*, QEvent*) ()
        at /home/frank/Projects/freecad-build/lib/libFreeCADGui.so
    0000038 0x00007ffff4fd28ad in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
        at /usr/lib/x86_64-linux-gnu/libQtCore.so.4
    #39 0x00007ffff550573d in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, 
    
    QWidget**, QPointer<QWidget>&, bool) () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    #40 0x00007ffff5583452 in  () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    0000041 0x00007ffff5582ce3 in QApplication::x11ProcessEvent(_XEvent*) () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    
    
    0000042 0x00007ffff55ac592 in  () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    ---Type <return> to continue, or q <return> to quit---
    0000043 0x00007fffedfc4387 in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
    0000044 0x00007fffedfc45c0 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
    0000045 0x00007fffedfc464c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
    
    
    0000046 0x00007ffff500320e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) 
    
    ()
        at /usr/lib/x86_64-linux-gnu/libQtCore.so.4
    0000047 0x00007ffff55ac666 in  () at /usr/lib/x86_64-linux-gnu/libQtGui.so.4
    0000048 0x00007ffff4fd112f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
        
    
    at /usr/lib/x86_64-linux-gnu/libQtCore.so.4
    0000049 0x00007ffff4fd1495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
        at /usr/lib/x86_64-linux-gnu/libQtCore.so.4
    0000050 0x00007ffff4fd7459 in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQtCore.so.4
    0000051 0x00007ffff7249a0a in Gui::Application::runApplication() ()
        at /home/frank/Projects/freecad-build/lib/libFreeCADGui.so
    0000052 0x00005555555573db in main ()
    
TagsNo tags attached.

Activities

wmayer

2019-01-13 17:14

administrator   ~0012424

Please have a look at: https://forum.freecadweb.org/viewtopic.php?f=4&t=33071&start=40

The actual problem is that two different Coin3d versions are loaded at runtime (one linked by libFreeCADGui.so and the other by pivy)

Check if an update is available that fixes the issue.

normandc

2019-02-24 15:47

manager   ~0012744

@FrankBlabu
Please report back.

FrankBlabu

2019-02-24 15:56

reporter   ~0012746

Yes, you are right, that seems to be the case on that machine. A fresh installation of the OS was performed for other reason and this issue vanished.

normandc

2019-02-24 16:28

manager   ~0012749

Thanks, I'm closing this ticket then.

Issue History

Date Modified Username Field Change
2018-12-26 18:30 FrankBlabu New Issue
2019-01-13 17:14 wmayer Note Added: 0012424
2019-01-13 17:14 wmayer Status new => feedback
2019-02-24 15:47 normandc Note Added: 0012744
2019-02-24 15:56 FrankBlabu Note Added: 0012746
2019-02-24 15:56 FrankBlabu Status feedback => new
2019-02-24 16:28 normandc Assigned To => normandc
2019-02-24 16:28 normandc Status new => closed
2019-02-24 16:28 normandc Resolution open => no change required
2019-02-24 16:28 normandc Note Added: 0012749