View Issue Details

IDProjectCategoryView StatusLast Update
0003729FreeCADBugpublic2018-12-24 16:28
Reportermrnuke Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target VersionFixed in Version0.18 
Summary0003729: REGRESSION: FreeCAD 0.17 does not export color information with STEP files
DescriptionWith FreeCAD 0.17, exporting a part as a STEP file does not preserve color information. Downgrading to FreeCAD 0.16 and exporting the same files produces the correct color information.
Steps To ReproduceOpen a *.fcstd part.
In the Model View, selecto the components to export.
Select File->Export
From "Files of Type" dropdown at the bottom select "STEP with colors (*.step *.stp)"
Save as a new file.
Open the new file in FreeCad.
TagsNo tags attached.
FreeCAD Information

Activities

mrnuke

2018-12-14 19:35

reporter   ~0012276

Example file which causes the issue

excelitas-as1052ac.fcstd (125,555 bytes)

mrnuke

2018-12-14 19:46

reporter   ~0012277

OS: Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.Unknown
Build type: Unknown
Python version: 2.7.15
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 6.9.1.oce-0.18
Locale: English/UnitedStates (en_US)

Kunda1

2018-12-14 23:30

administrator   ~0012278

please check 0.18 dev version https://github.com/FreeCAD/FreeCAD/releases/tag/0.18_pre

mrnuke

2018-12-15 02:54

reporter  

transforner-as1052-ac.step (854,515 bytes)

mrnuke

2018-12-15 02:54

reporter   ~0012279

I don't have the capability to compile freecad from source, so I had to run the 0.18-devel binary with wine. I see the same issue.

Also, I believe the problem is with opening the STEP file, not saving it. I am attaching a STEP file generated with freecad 0.16. 0.16 displays it just fine. 0.17 and 0.18 do not pick up the color information, and all sides are gray.

wmayer

2018-12-23 19:53

administrator   ~0012335

The colors for terminal-1,2,3 are correct but for some reason the color for the fusion object is not read-in.

wmayer

2018-12-24 16:28

administrator   ~0012340

https://github.com/FreeCAD/FreeCAD/commit/9c7128ea77fc1046e11ebf2fbeb41216446eac4f

Issue History

Date Modified Username Field Change
2018-12-14 19:32 mrnuke New Issue
2018-12-14 19:35 mrnuke File Added: excelitas-as1052ac.fcstd
2018-12-14 19:35 mrnuke Note Added: 0012276
2018-12-14 19:46 mrnuke Note Added: 0012277
2018-12-14 23:30 Kunda1 Note Added: 0012278
2018-12-15 02:54 mrnuke File Added: transforner-as1052-ac.step
2018-12-15 02:54 mrnuke Note Added: 0012279
2018-12-23 19:53 wmayer Status new => confirmed
2018-12-23 19:53 wmayer Note Added: 0012335
2018-12-24 16:28 wmayer Assigned To => wmayer
2018-12-24 16:28 wmayer Status confirmed => closed
2018-12-24 16:28 wmayer Resolution open => fixed
2018-12-24 16:28 wmayer Fixed in Version => 0.18
2018-12-24 16:28 wmayer Note Added: 0012340