View Issue Details

IDProjectCategoryView StatusLast Update
0003723Part[FreeCAD] Featurepublic2019-03-09 21:27
Reporterplaneanimal05 Assigned ToDeepSOIC  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
PlatformPersonal computer (PC)OSWindowsOS Version7
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.18 
Summary0003723: Part->Boolean->slice
DescriptionForum -> https://forum.freecadweb.org/viewtopic.php?f=8&t=32716

Consider an imported BOX_TOP.stl file which is imported and converted to a solid (Top (Solid)). There is a need to re-design a portion of the Top (Solid). This involves cutting a protrusion and stretching it. This video demonstrates https://youtu.be/36RPTGBAark

The steps needed make the cut create a "Slice" entry in the info tree. The feature/enhancement would be to have FreeCAD populate the tree with the entries "Top1 (Solid)" and "Top2 (Solid)" made visible so that the user can continue to edit the shapes.

Thank you
Steps To ReproduceNot a bug. No change to steps needed to perform the slice. Only the resulting info feedback to the user need be added.
Additional Information
OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git)
Build type: Release
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Tagsboolean, Part
FreeCAD Information

Issue History

Date Modified Username Field Change
2018-12-11 00:54 planeanimal05 New Issue
2018-12-11 00:54 planeanimal05 Tag Attached: boolean
2018-12-11 00:54 planeanimal05 Tag Attached: Part
2019-03-09 21:27 normandc Assigned To => DeepSOIC
2019-03-09 21:27 normandc Status new => closed
2019-03-09 21:27 normandc Resolution open => fixed
2019-03-09 21:27 normandc Fixed in Version => 0.18
2019-03-09 21:27 normandc Note Added: 0012871