View Issue Details

IDProjectCategoryView StatusLast Update
0003720Part[FreeCAD] Bugpublic2018-12-23 09:06
ReporterSami JounaidAssigned ToKunda1 
PriorityhighSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version 
Summary0003720: Sweep: / path = arc R x 90 degree / profile = square L x L / when R < 0.5 * L
Descriptionhttps://drive.google.com/open?id=1kdMvpHInnSzfhBgSy_YhXyhiGbeBgzpj
Steps To Reproducehttps://drive.google.com/open?id=1kdMvpHInnSzfhBgSy_YhXyhiGbeBgzpj
Additional Informationhttps://drive.google.com/open?id=1kdMvpHInnSzfhBgSy_YhXyhiGbeBgzpj
TagsNo tags attached.

Activities

Sami Jounaid

2018-12-09 16:18

reporter  

sweepfail.FCStd (16,742 bytes)
sweep-fail.png (9,369 bytes)
sweep-fail.png (9,369 bytes)

Kunda1

2018-12-10 12:00

manager   ~0012252

Please open a forum thread to discuss this (as we ask in the enormous yellow banner at the top of the every bugtracker page). Also please test this issue in the 0.18dev release first https://github.com/FreeCAD/FreeCAD/releases/tag/0.18_pre

Sami Jounaid

2018-12-10 16:09

reporter   ~0012257

https://forum.freecadweb.org/viewtopic.php?f=3&t=32701

Sami Jounaid

2018-12-10 19:00

reporter   ~0012258

same in 0.18 too

Sami Jounaid

2018-12-11 13:48

reporter   ~0012262

Hello Kunda1 ,
I made the following :
*- Export the sweep as .iges
*- import it to SolidWorks

So I found that lost faces are there, but it is not good enough.

Screenshot_1.png (70,106 bytes)
Screenshot_1.png (70,106 bytes)

Kunda1

2018-12-20 13:37

manager   ~0012331

https://forum.freecadweb.org/viewtopic.php?f=3&t=32701&p=275272#p275272

chrisb

2018-12-23 09:06

developer   ~0012334

The solid has self intersections, thus it's not a bug.

Issue History

Date Modified Username Field Change
2018-12-09 16:18 Sami Jounaid New Issue
2018-12-09 16:18 Sami Jounaid File Added: sweepfail.FCStd
2018-12-09 16:18 Sami Jounaid File Added: sweep-fail.png
2018-12-10 12:00 Kunda1 Assigned To => Kunda1
2018-12-10 12:00 Kunda1 Status new => feedback
2018-12-10 12:00 Kunda1 Note Added: 0012252
2018-12-10 16:09 Sami Jounaid Note Added: 0012257
2018-12-10 16:09 Sami Jounaid Status feedback => assigned
2018-12-10 19:00 Sami Jounaid Note Added: 0012258
2018-12-11 13:48 Sami Jounaid File Added: Screenshot_1.png
2018-12-11 13:48 Sami Jounaid Note Added: 0012262
2018-12-20 13:37 Kunda1 Note Added: 0012331
2018-12-23 09:06 chrisb Status assigned => closed
2018-12-23 09:06 chrisb Resolution open => no change required
2018-12-23 09:06 chrisb Note Added: 0012334