View Issue Details

IDProjectCategoryView StatusLast Update
0003717FreeCADBugpublic2019-03-22 11:08
ReporterWitold Baryluk Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status feedbackResolutionreopened 
Product Version0.17 
Target Version0.19Fixed in Version 
Summary0003717: FreeCAD AppImage fails to start: failed to create drawable
DescriptionDownload recent AppImage for FreeCad from https://www.freecadweb.org/downloads.php

make it executable, and run:


user@debian:~/Downloads$ ./FreeCAD-0.17.13541.9948ee4.glibc2.17-x86_64.AppImage
FreeCAD 0.17, Libs: 0.17R13541 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2018
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##

failed to create drawable
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
freecad: ../../src/xcb_io.c:263: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
Aborted
$
Steps To ReproduceIn the description.
Additional Informationn/a
Tagsappimage, Assertion, linux
FreeCAD Information

Relationships

related to 0003737 closed neue Installation startet nicht 

Activities

Kunda1

2018-12-07 23:46

administrator   ~0012241

After doing extensive research
it turns out it's a known issue:
https://forum.freecadweb.org/viewtopic.php?style=4&f=4&t=28054&start=10

Please read the enormous yellow banner at the top of the page. Thanks.

Witold Baryluk

2018-12-08 00:33

reporter   ~0012242

I did search in a tracker. There are no open issues about this.

Is it fixed? Because if not, then why you would close the issue?

Kunda1

2018-12-10 13:34

administrator   ~0012256

OP please read the threads and utilize the workaround. Does it work ?

Witold Baryluk

2018-12-12 15:14

reporter   ~0012264

Are you talking about `LIBGL_DRI3_DISABLE=true`?

I am able to start up the ./FreeCAD-0.17.13541.9948ee4.glibc2.17-x86_64.AppImage with this environment variable set now, and it appears to be working (only tested 3 workspaces). The style of windows, menus and some fonts, looks rather wrong to me, but I have no idea if this is related to appimage or to this flag.

I have also freecad from Debian installed, and it works perfectly. No flags. Correct window and menu styles, font sizes, etc.

So, workaround kind of works indeed. Still, would be good to understand the actual problem.

Why is the Debian package working fine?

Testing the debian package, I see it is using DRI3:


strace -f freecad 2>&1 | grep -i dri3
[pid 68012] openat(AT_FDCWD, "/lib/x86_64-linux-gnu/libxcb-dri3.so.0", O_RDONLY|O_CLOEXEC) = 22
[pid 68012] writev(3, [{iov_base="b\0\3\0\4\0\0\0DRI3b\0\4\0\7\0\0\0Present\0", iov_len=28}], 1) = 28

Regards,
Witold

Witold Baryluk

2018-12-12 15:15

reporter   ~0012265

BTW. I do not use wayland. It is just a MATE Desktop with standard Xorg server and marco window manager.

Kunda1

2018-12-12 23:51

administrator   ~0012267

Yea, best to continue this discussion on the forum. Choose a thread (not older than a year) and post to it or create a whole new thread. We prefer to discuss such things in the forum.

Kunda1

2018-12-18 11:42

administrator   ~0012301

Looks like there is a duplicate 0003737

Kunda1

2018-12-19 09:21

administrator   ~0012308

OP please have a look at the @wmayers (core-developer) response: 0003737:0012302

Kunda1

2019-01-05 11:57

administrator   ~0012385

@wmayer is this the same issue as 0003737 and can this be closed ?

wmayer

2019-01-09 10:13

administrator   ~0012401

Yes, it's the same issue.

Witold Baryluk

2019-01-09 10:26

reporter   ~0012402

I am happy to discuss things on forum if you stop closing the issue report about a bug that is still not fixed or resolved.

Witold Baryluk

2019-01-09 10:33

reporter   ~0012403

Tested 0.18dev release, with same effect.


$ ./FreeCAD_0.18.15536.glibc2.17-x86_64.AppImage 
FreeCAD 0.18, Libs: 0.18R15536 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2018
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

failed to create drawable
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
freecad-daily: ../../src/xcb_io.c:263: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
Aborted
$

We did follow your "rules" too:

We are observing many reporters do not:

(1) First post to forum to verify their issue; - DONE. It is verified.

(2) Link said thread to ticket and vice-a-versa; - DONE. We have a link to this thread and vice a versa.

(3) Use the most updated stable or development versions of FreeCAD; - DONE. Still there.

(4) Post their Help>About FreeCAD>Copy to clipboard version info; - Not possible.

(5) Post a Step-By-Step explanation on how to recreate the issue; - DONE.

(6) Neglect to upload an example file to demonstrate problem. - DONE. Not applicable.

Kunda1

2019-01-25 23:09

administrator   ~0012515

OP did you read the workaround mentioned in 0003737:0012302 ?
type this in your terminal before starting FC:
export LIBGL_DRI3_DISABLE=true

Kunda1

2019-02-27 21:28

administrator   ~0012791

ping

Kunda1

2019-03-22 11:05

administrator   ~0012941

Ugly workaround:

I tried backstepping mesa from 18.0.0 to 17.3.7 and that resolved my issue without resorting to DRI disables.

salmino

Issue History

Date Modified Username Field Change
2018-12-06 21:52 Witold Baryluk New Issue
2018-12-06 21:52 Witold Baryluk Tag Attached: appimage
2018-12-06 21:52 Witold Baryluk Tag Attached: Assertion
2018-12-06 21:52 Witold Baryluk Tag Attached: linux
2018-12-07 23:46 Kunda1 Assigned To => Kunda1
2018-12-07 23:46 Kunda1 Status new => resolved
2018-12-07 23:46 Kunda1 Resolution open => no change required
2018-12-07 23:46 Kunda1 Note Added: 0012241
2018-12-08 00:33 Witold Baryluk Status resolved => feedback
2018-12-08 00:33 Witold Baryluk Resolution no change required => reopened
2018-12-08 00:33 Witold Baryluk Note Added: 0012242
2018-12-10 13:34 Kunda1 Note Added: 0012256
2018-12-12 15:14 Witold Baryluk Note Added: 0012264
2018-12-12 15:14 Witold Baryluk Status feedback => assigned
2018-12-12 15:15 Witold Baryluk Note Added: 0012265
2018-12-12 23:51 Kunda1 Note Added: 0012267
2018-12-18 11:41 Kunda1 Relationship added related to 0003737
2018-12-18 11:42 Kunda1 Note Added: 0012301
2018-12-19 09:21 Kunda1 Note Added: 0012308
2018-12-19 09:23 Kunda1 Assigned To Kunda1 =>
2018-12-19 09:23 Kunda1 Status assigned => resolved
2018-12-19 09:23 Kunda1 Resolution reopened => no change required
2019-01-05 11:57 Kunda1 Note Added: 0012385
2019-01-09 10:13 wmayer Note Added: 0012401
2019-01-09 10:26 Witold Baryluk Status resolved => feedback
2019-01-09 10:26 Witold Baryluk Resolution no change required => reopened
2019-01-09 10:26 Witold Baryluk Note Added: 0012402
2019-01-09 10:33 Witold Baryluk Note Added: 0012403
2019-01-09 10:33 Witold Baryluk Status feedback => new
2019-01-25 21:28 Kunda1 Summary FreeCAD AppImage fils to start: failed to create drawable => FreeCAD AppImage fails to start: failed to create drawable
2019-01-25 23:09 Kunda1 Note Added: 0012515
2019-01-25 23:09 Kunda1 Status new => feedback
2019-02-27 21:28 Kunda1 Severity block => major
2019-02-27 21:28 Kunda1 Note Added: 0012791
2019-03-22 11:05 Kunda1 Note Added: 0012941
2019-03-22 11:08 Kunda1 Target Version => 0.19