View Issue Details

IDProjectCategoryView StatusLast Update
0003712FreeCADBugpublic2019-01-25 21:27
ReporterAndiTheBest Assigned ToKunda1  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSMintOS Version19
Product Version0.18 
Target VersionFixed in Version 
Summary0003712: Crash when importing .svg file (only linux version)
DescriptionHi.

I've created a .svg file with Gimp and Inkscape. When trying to import as geometry, FreeCad crashes. Tried Stable and Daily.
When using the windows version of FreeCad, it works. So only the Linux build is affected.

Program received signal SIGSEGV, Segmentation fault.
#0  /lib/x86_64-linux-gnu/libc.so.6(+0x3ef20) [0x7fca32495f20]
#1  /lib/x86_64-linux-gnu/libexpat.so.1(XML_SetHashSalt+0x1b) [0x7fca27ae2fcb]
0000002  /usr/lib/python2.7/lib-dynload/pyexpat.x86_64-linux-gnu.so(+0x6968) [0x7fc9a9950968]
0000003  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x6ff3) [0x7fca340831b3]
0000004  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x8b5b) [0x7fca34084d1b]
0000005  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x8b5b) [0x7fca34084d1b]
0000006  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x8b5b) [0x7fca34084d1b]
0000007  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x7d8) [0x7fca341b4278]
0000008  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalCode+0x19) [0x7fca3407c029]
0000009  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyRun_StringFlags+0x76) [0x7fca3411f546]
0000010  0x7fca3460bd76 in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /usr/lib/freecad-daily/lib/libFreeCADBase.so+0x66
0000011  0x7fca35258ba3 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) from /usr/lib/freecad-daily/lib/libFreeCADGui.so+0x123
0000012  0x7fca351b3974 in Gui::Application::importFrom(char const*, char const*, char const*) from /usr/lib/freecad-daily/lib/libFreeCADGui.so+0x124
0000013  0x7fca35265c2a in StdCmdImport::activated(int) from /usr/lib/freecad-daily/lib/libFreeCADGui.so+0x61a
0000014  0x7fca3525dfdb in Gui::Command::invoke(int) from /usr/lib/freecad-daily/lib/libFreeCADGui.so+0x7b
0000015  0x7fca32f8cf70 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x4d0
0000016  0x7fca3349edc2 in QAction::triggered(bool) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x42
0000017  0x7fca334a0113 in QAction::activate(QAction::ActionEvent) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x83
0000018  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x62236d) [0x7fca3390236d]
0000019  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x626759) [0x7fca33906759]
0000020  0x7fca334fb930 in QWidget::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x2a0
0000021  0x7fca3390a96b in QMenu::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x6b
0000022  0x7fca334a503c in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x8c
0000023  0x7fca334ac136 in QApplication::notify(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x476
0000024  0x7fca352314c8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad-daily/lib/libFreeCADGui.so+0x88
0000025  0x7fca32f788ad in QCoreApplication::notifyInternal(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x8d
0000026  0x7fca334ab73d in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x14d
0000027  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x249ddc) [0x7fca33529ddc]
0000028  0x7fca33528ce3 in QApplication::x11ProcessEvent(_XEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x16b3
0000029  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x272592) [0x7fca33552592]
0000030  /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x2e7) [0x7fca2bd3a287]
0000031  /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x4c4c0) [0x7fca2bd3a4c0]
0000032  /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7fca2bd3a54c]
0000033  0x7fca32fa920e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x7e
0000034  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x272666) [0x7fca33552666]
0000035  0x7fca32f7712f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x3f
0000036  0x7fca32f77495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x1b5
0000037  0x7fca32f7d459 in QCoreApplication::exec() from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x99
0000038  0x7fca351bda7a in Gui::Application::runApplication() from /usr/lib/freecad-daily/lib/libFreeCADGui.so+0x16ba
#39  freecad-daily(main+0x6db) [0x55a91303041b]
#40  /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7fca32478b97]
0000041  freecad-daily(_start+0x2a) [0x55a9130315ca]
Steps To ReproduceFile->New
File->Import
choose attached svg
SVG as geometry
Additional InformationOS: Linux Mint 19 Tara
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15302 (Git)
Build type: Release
Branch: master
Hash: 2e03d2f298677b8212c22cbbc3cb20b7c80eabb5
Python version: 2.7.15rc1
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Austria (de_AT)
TagsNo tags attached.
FreeCAD Information

Activities

AndiTheBest

2018-12-03 00:24

reporter  

niko9.svg (5,540 bytes)

Kunda1

2018-12-10 11:35

administrator   ~0012249

Looks like the libexpat dependency regression 0003557
You need to downgrade libexpat. Please search or ask on the forums next time before opening a ticket (as we request in the enormous yellow banner at the top of the tracker).

Kunda1

2019-01-25 21:27

administrator   ~0012514

Closed

Issue History

Date Modified Username Field Change
2018-12-03 00:24 AndiTheBest New Issue
2018-12-03 00:24 AndiTheBest File Added: niko9.svg
2018-12-10 11:35 Kunda1 Assigned To => Kunda1
2018-12-10 11:35 Kunda1 Status new => resolved
2018-12-10 11:35 Kunda1 Resolution open => no change required
2018-12-10 11:35 Kunda1 Note Added: 0012249
2019-01-25 21:27 Kunda1 Status resolved => closed
2019-01-25 21:27 Kunda1 Note Added: 0012514