View Issue Details

IDProjectCategoryView StatusLast Update
0003700PartDesignBugpublic2019-01-13 23:48
ReporterkkremitzkiAssigned Tokkremitzki 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target Version0.18Fixed in Version0.18 
Summary0003700: Tree object deletion possible with keyboard but not right-click menu in Part Design
DescriptionWhen the Part Design workbench is activated, if one presses the 'del' key on the keyboard, a warning pops up about the dangers of such an action. However, it isn't possible to trigger that prompt to delete by right clicking an object in the tree view, because the option to delete is missing. If it's possible to delete with 'del', it should also be possible via mouse.
TagsNo tags attached.

Activities

kkremitzki

2018-11-17 22:26

administrator   ~0012209

NormandC wrote

Cut/Copy/Paste are missing as well, and their functionality is available from the Edit menu or the standard toolbar; so it should be the same for them

wmayer

2019-01-13 23:48

administrator   ~0012428

https://github.com/FreeCAD/FreeCAD/commit/53eb746e1a6015760324a3a8e65dd4382ae228da

Issue History

Date Modified Username Field Change
2018-11-17 22:22 kkremitzki New Issue
2018-11-17 22:22 kkremitzki Status new => assigned
2018-11-17 22:22 kkremitzki Assigned To => kkremitzki
2018-11-17 22:22 kkremitzki Project FreeCAD => PartDesign
2018-11-17 22:26 kkremitzki Note Added: 0012209
2019-01-13 23:48 wmayer Status assigned => closed
2019-01-13 23:48 wmayer Resolution open => fixed
2019-01-13 23:48 wmayer Fixed in Version => 0.18
2019-01-13 23:48 wmayer Note Added: 0012428