View Issue Details

IDProjectCategoryView StatusLast Update
0003695Path[FreeCAD] Bugpublic2019-01-22 04:02
ReporterTheRainHarvesterAssigned Tosliptonic 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionnot fixable 
PlatformwinOS8.1OS VersionPro
Product Version[FreeCAD] 0.18 
Target VersionFixed in Version 
Summary0003695: "Simple Copy Button" (ie non-parametric copy), doesn't work.
DescriptionUsage scenario: I want to cut a lot of the same parts on CNC.
I have a Helix001 path.
Copying the path with the "Simple Copy Button" does not produce gcode correctly.
(it produces repeated cuts in the same location even when placement is different.)
Steps To ReproduceOpen attached file
Notice the lower paths (which are the copy). The copy shows the correct placement.

Click "post process" and save the file. In the file, Notice that the path is not correctly displaced downward but instead repeats the same locations.

You can see this line is repeated twice:
G2 X15.2730 Y-19.9421 Z-0.3667 I-1.4500 J0.0000 F500.00

The second occurrence should be placed down in the Y direction.
You can also see this if viewing the file in a gcode simulator (Camotics).
Additional InformationOS: Windows 8.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15214 (Git)
Build type: Release
Branch: master
Hash: b3721f8613b975be13e1801f499fa06f6f0ad836
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)
TagsNo tags attached.

Activities

TheRainHarvester

2018-11-16 18:47

reporter  

BugCopyPathThenDisplaceDoesntWork.FCStd (347,632 bytes)

sliptonic

2019-01-22 04:02

developer   ~0012482

This is a misunderstanding of how simple copy works. It isn't intended to make multiple copies in different locations. It's intended to make a non-parametric copy of a path which can then be hand-edited.

Also, the placement property of Paths only affects how gcode is visualized in the 3D workspace not where it is generated in the machine coordinate space.

For your use-case, a better approach is to use Path-Array. if the copies can be described in a polar or linear array. Otherwise, you might have to make copies of your base object and use a multi-base job.

Issue History

Date Modified Username Field Change
2018-11-16 18:47 TheRainHarvester New Issue
2018-11-16 18:47 TheRainHarvester File Added: BugCopyPathThenDisplaceDoesntWork.FCStd
2019-01-22 04:02 sliptonic Assigned To => sliptonic
2019-01-22 04:02 sliptonic Status new => closed
2019-01-22 04:02 sliptonic Resolution open => not fixable
2019-01-22 04:02 sliptonic Note Added: 0012482